Xoutpost.com

Xoutpost.com (https://xoutpost.com/forums.php)
-   X5 (E70) Forum (https://xoutpost.com/bmw-sav-forums/x5-e70-forum/)
-   -   Malfunction Lights for Christmas... (https://xoutpost.com/bmw-sav-forums/x5-e70-forum/85159-malfunction-lights-christmas.html)

buckeyewalt 12-28-2011 08:47 PM

Quote:

Originally Posted by rh71 (Post 858147)
It's recharged when inserted as per your manual. If you have comfort access, it is not rechargeable as it uses a regular CR2032 battery. Curious - how long has it not been inserted that it would say that?


Thanks for the respponse,,,,,I do have comfort access...however,,,sometimes when I insert the key into the slot,,,,magically the warning triangle goes away after driving it a few minutes....so that's was my assumption that it was recharging itself,,,,but then I looked in the book and it says to replace the battery with the battery that you quoted,,,,,I am really confused on this. Normally I would take it to the dealer to get it fixed,,but since I am about 1 1/2 hours away from the nearest dealer,,,I thought I would go this route first and see if anyone else had this issue. If the key fob just needs a battery,,,that should be a simple fix,,,BUT still kind of curious about the charging routine......Thanks!!!

3Series 12-29-2011 02:28 PM

What specific battery did you get at advanced auto? Model number? Or did you just go "by the book'?

3Series 12-29-2011 02:31 PM

Quote:

Originally Posted by buckeyewalt (Post 858193)
Thanks for the respponse,,,,,I do have comfort access...however,,,sometimes when I insert the key into the slot,,,,magically the warning triangle goes away after driving it a few minutes....so that's was my assumption that it was recharging itself,,,,but then I looked in the book and it says to replace the battery with the battery that you quoted,,,,,I am really confused on this. Normally I would take it to the dealer to get it fixed,,but since I am about 1 1/2 hours away from the nearest dealer,,,I thought I would go this route first and see if anyone else had this issue. If the key fob just needs a battery,,,that should be a simple fix,,,BUT still kind of curious about the charging routine......Thanks!!!


I didn't read all your posts, but try replacing the battery in the fob and see if that does anything. Maybe the car is telling you the battery is dying and you should replace it.....since you have CA, it doesn't charge anything.

buckeyewalt 12-29-2011 07:19 PM

Quote:

Originally Posted by 3Series (Post 858327)
I didn't read all your posts, but try replacing the battery in the fob and see if that does anything. Maybe the car is telling you the battery is dying and you should replace it.....since you have CA, it doesn't charge anything.

This was my thought also,,,however,,,whenever I drive the vehhicle,,,the triangle light goes out after about 5-8 minutes worth or driving,,,and then it comes back on in city type driving,,,or stop and go..I really hope that the main battery is not going out,,,I know that it's in warranty,,,but a pain to get everything set on the vehicle..........

gnathologist 01-04-2012 01:15 AM

Hello guys,

A quick update on my X5. The dealership swap out the DME and everything is working well without throwing any codes. The 45 minute drive home from the dealership was uneventful.

Asked my service advisor about how they came to the diagnosis of faulty DME. He simply said, "all the testings led to your DME."

I'm sorry I can't provide more specific information on the exact reason for all the malfunction lights, other than a faulty DME. Swapping out the DME may have been the easiest fix for the dealership in my case...
All the years I have own multiple cars, this was the first time a DME had to be replaced.

I hope this will take care of the problems.

chuppa 08-16-2012 12:33 PM

Quote:

Originally Posted by gnathologist (Post 859011)
Hello guys,

A quick update on my X5. The dealership swap out the DME and everything is working well without throwing any codes. The 45 minute drive home from the dealership was uneventful.

Asked my service advisor about how they came to the diagnosis of faulty DME. He simply said, "all the testings led to your DME."

I'm sorry I can't provide more specific information on the exact reason for all the malfunction lights, other than a faulty DME. Swapping out the DME may have been the easiest fix for the dealership in my case...
All the years I have own multiple cars, this was the first time a DME had to be replaced.

I hope this will take care of the problems.

Have you had anymore issues since the DME swap? Our X5 is going thru this and we are at that point as well. Was hoping for some good results this time. Thx.

gnathologist 08-16-2012 04:05 PM

Haven't had any problems since the swap. I did not want to take any chance being stranded with my kids, so I traded it in with a new 7 series.
Hopefully the new 7 series will be more reliable...

Wish everything works out for your X5.

Ex5 owner...

buckeyewalt 08-16-2012 04:35 PM

Quote:

Originally Posted by gnathologist (Post 891732)
Haven't had any problems since the swap. I did not want to take any chance being stranded with my kids, so I traded it in with a new 7 series.
Hopefully the new 7 series will be more reliable...

Wish everything works out for your X5.

Ex5 owner...

I finally got my car(truck) back about 3 weeks ago. So far everything seems to be Ok,,,this is after they replaced about $12,000 in parts not counting labor. I had a 7 series for a loaner in the begining, but it's not the car (type) for me....seems to working out for you though. Hope you have luck with the 7, and hopefully they "finally" fixed my issues....so far,,,so good...by the way,,the car was in the shop almost 90 days!!!

chuppa 08-16-2012 05:19 PM

Quote:

Originally Posted by gnathologist (Post 891732)
Haven't had any problems since the swap. I did not want to take any chance being stranded with my kids, so I traded it in with a new 7 series.
Hopefully the new 7 series will be more reliable...

Wish everything works out for your X5.

Ex5 owner...

Thanks for the response. I too get worried as this is my wife's primary vehicle. The DME has been replaced and also the telecommunication module which has been identified as the real problem (bluetooth/SOS module). The dealership says all has been tested and in working order. Getting it put together right now and picking it up tomorrow morning. I hope this fixes it all.

zx45 08-16-2012 06:28 PM

keep us updated and good luck.


All times are GMT -4. The time now is 10:30 PM.

vBulletin, Copyright 2020, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved.