Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X3 (E83) Forum
Arnott
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-13-2007, 08:08 AM
Member
 
Join Date: Jul 2007
Location: Alaska
Posts: 39
Skimo100 is on a distinguished road
Question Blue Sirius Connector Missing, X3 2007 3.0si

I installed the sirius receiver using the sirius installation kit (for no nav) for my 2007 X3, 3.0si, which comes "prewired for sat". After installing it, all I get is the "aquiring" message on my radio screen, with a good and clear line of sight to the sky. Going back, and trying to figured out the steps....i noticed that there was only one sirius antenna connector on the wire bundle. The color was white and not blue. According to the intructions sent by circle BMW, there should be two connectors one white (which is not to be used for this installtion) and a blue one (which is to be changed with the curry connector that comes with the installation kit). However, the blue connector is missing. And the white connector, which I changed instead of the blue (since the blue is missing) with the curry connector appears to not be connected to the shark-fin antenna. Has anyone had this problem before of having the sirius blue connector missing????? (although is supposed to be pre-wired for sat according to specs on the 2007 X3 3.0is models). Is this common with the 2007 X3 that come pre-wired for sat? Any help will be greatly appreciated.
Reply With Quote

Sponsored Links

  #2  
Old 07-13-2007, 04:56 PM
Member
 
Join Date: Aug 2005
Location: TX
Posts: 233
Derek is on a distinguished road
It sounds like you have an early production model. We had the same problem when I tried to install mine. You need to contact the dealer..... There is a SIB document that details what they need to modify. Basically BMW installed the antenna incorrectly.
Reply With Quote
  #3  
Old 07-13-2007, 05:35 PM
stangmatt66's Avatar
Member
 
Join Date: Feb 2007
Location: Orange County, CA, USA
Posts: 51
stangmatt66 is on a distinguished road
Some early production 07's were not pre-wired as advertised. Your BMW center will fix this free of charge.
__________________
2007 X3 3.0si - ED 07/30/07 :: Montego Blue :: Sand/Black Nevada Leather :: Brushed Aluminum :: Steptronic Transmission :: Premium Pack :: Heated Steering Wheel :: Heated Front Seats :: Premium Audio :: Navigation :: Xenons :: 18" Wheels

Ongoing ED Timeline:
07/30 - Picked up in Munich. 08/02 - Dropped off in Munich, 08/16 - Set sail aboard the Boheme, 09/09 - Boheme arrived in Port Hueneme, CA, 09/18 - Redelivery

MSBCreations.com / My tumblr
Reply With Quote
  #4  
Old 07-13-2007, 07:43 PM
Tom G.'s Avatar
Premier Member
 
Join Date: Aug 2005
Location: X5world
Posts: 3,228
Tom G. is on a distinguished road
Quote:
Originally Posted by Skimo100
I installed the sirius receiver using the sirius installation kit (for no nav) for my 2007 X3, 3.0si, which comes "prewired for sat". After installing it, all I get is the "aquiring" message on my radio screen, with a good and clear line of sight to the sky. Going back, and trying to figured out the steps....i noticed that there was only one sirius antenna connector on the wire bundle. The color was white and not blue. According to the intructions sent by circle BMW, there should be two connectors one white (which is not to be used for this installtion) and a blue one (which is to be changed with the curry connector that comes with the installation kit). However, the blue connector is missing. And the white connector, which I changed instead of the blue (since the blue is missing) with the curry connector appears to not be connected to the shark-fin antenna. Has anyone had this problem before of having the sirius blue connector missing????? (although is supposed to be pre-wired for sat according to specs on the 2007 X3 3.0is models). Is this common with the 2007 X3 that come pre-wired for sat? Any help will be greatly appreciated.
Can you post a picture of your connections - we'll be able to determine a fix right away.
__________________
Tom G. | european auto source (eas)
email: [email protected] web: www.europeanautosource.com
tel 866.669.0705 | ca: 714.369.8524 x22 | fax: 714.908.1796


Twitter | Flikr | Facebook | YouTube
Reply With Quote
  #5  
Old 07-13-2007, 09:44 PM
Member
 
Join Date: Jul 2007
Location: Alaska
Posts: 39
Skimo100 is on a distinguished road
Quote:
Originally Posted by Tom G.
Can you post a picture of your connections - we'll be able to determine a fix right away.
I'll take pics after I do some troubleshooting first. The problem appears to be the antenna wiring leading from the sirius receiver to the shark fin antenna connector. Everything else is connected correctly. However, there is also the possibility that the Sirius receiver I got came defective.

It would be nice if someone can use a digital ohm meter and disconnect their sirius antenna connector from their sirius receiver to see if it is the same value I'm measuring here from center pin to the outter rim of the connector at the antenna cable (not on the receiver's connector).
Reply With Quote
  #6  
Old 07-14-2007, 10:02 PM
JSY JSY is offline
Member
 
Join Date: Dec 2006
Location: New York, NY
Posts: 18
JSY is on a distinguished road
Like Stangmatt66 said, some early production X3's did not have the white connector properly wired to the sharkfin antenna. There was a service bulletin on this so BMW will fix it without problem. My X3 was produced in December and it was properly connected (did a self Sirius install as well).

The antenna connector with the white plug removed (and before installing the curry connector) can actually connect to a regular Sirius satellite (or even XM) radio so that would be a way to test if you actually had the means - but that is sort of a hassel.
Reply With Quote
  #7  
Old 03-27-2013, 11:50 PM
Member
 
Join Date: Mar 2013
Location: New jersey
Posts: 2
Rmerkushen is on a distinguished road
Looking for that service bulletin.. If anyone still has it please post it. Have early 2007 model and sat antenna is not working..

Thanks!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 12:09 PM.
vBulletin, Copyright 2018, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.