Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E53) Forum
Arnott
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #11  
Old 11-29-2015, 04:15 PM
Qsilver7's Avatar
Member
 
Join Date: Oct 2012
Location: Indiana, USA
Posts: 3,362
Qsilver7 is on a distinguished road
just some FYI about the pneumatic single & dual suspensions: (the dual axle diagram is reduced/smaller than the single axle only so that both diagrams fit equally...because all the stuff under the dome in the rear is actually the same size whether single or dual system...and so are the shocks respectively)





__________________
{BMW CCA Member #191509 - (for more info see: www.bmwcca.org)}
  • 2013 f06 650ix GC (1/13 build date) Black Sapphire exterior/Schwarz (black) Nappa Leather interior
  • 2006 e53 X5 4.4i (12/05 build date) Sterling Gray exterior/Schwarz (black) Dakota Leather interior
  • 1997 e38 740iL (sold) Arctic Silver
  • 1999 e39 540iT (sold) Orient Blue
  • 1995 e34 525iT (sold) Alpine White
  • 1991 e32 735iL (sold) Schwarz (black)
  • 1985 e30 325e (sold) Bronzit
Reply With Quote

Sponsored Links

  #12  
Old 11-29-2015, 05:27 PM
Member
 
Join Date: Mar 2009
Location: ATLANTA..DAWG country
Posts: 119
KDAWG97M3 is on a distinguished road
Well I can clear the codes and get the pump to work. When I hit the level switch the lights blink. Sometimes it raises the car some times it doesn't. Seems the front raises but the rear doesn't. I will get a rebuild kit and see
If it fixes it. I took the pump apart the cylinder walls looks ok. The little plastic gasket looks worn and has some nics. Nothing that I see that would cause issues, but i willing to try anything at this point

I also reset the unit...just to tell step by step

So I have been driving around and the pump comes on but I see no movement. But no fault either? I press the ride height buttons and still nothing. Even when I press to lower the car, I can hear it hissing, but the car isn't lowering?!?!? Could this be the Control module and weak pump? This is really frustrating

Also I tested my battery 14.1volts at idle So we are good on that front
__________________
2013 X5 35D
2015 F350
2009 E90 M3
2007 GT3
1996 993 C4S
1991 964 Turbo
1994 D90
1989 E30 M3
1988 E30 M3
1972 cutlass supreme


-sold-
1993 E34 S52 supercharged wagon
1988 E30 M3 henna
2002 E46 M3
1997 E36 M3
2001 X5
2006 4.8is
1998 e36 M3 track car
1995 e36 M3 track car

Last edited by KDAWG97M3; 11-29-2015 at 07:08 PM.
Reply With Quote
  #13  
Old 11-29-2015, 09:58 PM
BimmerE38E53's Avatar
Member
 
Join Date: Jul 2015
Location: Simpsonville, SC
Posts: 191
BimmerE38E53 is on a distinguished road
Just my 2 cents.....I recently had similar problems. My led switch wouldn't work. When I went out in the mornings the front left would be down. This actually triggered the SLS Inactive warning. I had a leaky airbag. Replace bag and still had the warning. Car didn't leak down anymore but warning still there and led switch lit, but still not workings. Replaced my EHC module coded to car, took about 10 minutes and error message Gone. Switch works now and no more SLS Inactive warning. Not cheap, but did solve my problem.
Reply With Quote
  #14  
Old 11-30-2015, 09:10 PM
Member
 
Join Date: Mar 2009
Location: ATLANTA..DAWG country
Posts: 119
KDAWG97M3 is on a distinguished road
Update:

I took the pump apart and cleaned it, fiddled with the round piston gasket, lifted the small gaskets cleaned it, put the pump back together, I have driven 100 miles no error (knock on wood) the rode height adjuster button doesn't work correctly..only the front of the car lifts, the back doesn't, the pump runs occasionally but not excessively. I am going to get my guy to calibrate it and see if we can trouble shoot some more..but my inactive light is gone...for now..again knock on wood..just providing a update
__________________
2013 X5 35D
2015 F350
2009 E90 M3
2007 GT3
1996 993 C4S
1991 964 Turbo
1994 D90
1989 E30 M3
1988 E30 M3
1972 cutlass supreme


-sold-
1993 E34 S52 supercharged wagon
1988 E30 M3 henna
2002 E46 M3
1997 E36 M3
2001 X5
2006 4.8is
1998 e36 M3 track car
1995 e36 M3 track car
Reply With Quote
  #15  
Old 12-02-2015, 09:08 PM
Member
 
Join Date: Mar 2009
Location: ATLANTA..DAWG country
Posts: 119
KDAWG97M3 is on a distinguished road
Just an FYI.....I purchased a control module for what I think is a dual air suspension I think it is only for a two axle car...can someone verify this part number? It shows for a 4.8, but I can't find the same looking module. 37146874414
__________________
2013 X5 35D
2015 F350
2009 E90 M3
2007 GT3
1996 993 C4S
1991 964 Turbo
1994 D90
1989 E30 M3
1988 E30 M3
1972 cutlass supreme


-sold-
1993 E34 S52 supercharged wagon
1988 E30 M3 henna
2002 E46 M3
1997 E36 M3
2001 X5
2006 4.8is
1998 e36 M3 track car
1995 e36 M3 track car
Reply With Quote
  #16  
Old 12-02-2015, 09:30 PM
Qsilver7's Avatar
Member
 
Join Date: Oct 2012
Location: Indiana, USA
Posts: 3,362
Qsilver7 is on a distinguished road
The 4.8is only came with dual axle self leveling...so a quick diagram look up on realoem.com should give you the part number you need. The number you posted...when entered into the part number search pulls up the 4.6 is...since that model came with rear single axle only...that wouldn't work for the dual axle.

I used a 2006 4.8is with a 1/2006 build date to pull up the diagram: RealOEM.com - Online BMW Parts Catalog

If you click on the 11 digit part number at the link above...it will show the old part numbers that this latest number supersedes. So if your looking for used ones...those other 3 numbers would be the ones that are compatible.
__________________
{BMW CCA Member #191509 - (for more info see: www.bmwcca.org)}
  • 2013 f06 650ix GC (1/13 build date) Black Sapphire exterior/Schwarz (black) Nappa Leather interior
  • 2006 e53 X5 4.4i (12/05 build date) Sterling Gray exterior/Schwarz (black) Dakota Leather interior
  • 1997 e38 740iL (sold) Arctic Silver
  • 1999 e39 540iT (sold) Orient Blue
  • 1995 e34 525iT (sold) Alpine White
  • 1991 e32 735iL (sold) Schwarz (black)
  • 1985 e30 325e (sold) Bronzit
Reply With Quote
  #17  
Old 12-02-2015, 09:41 PM
Member
 
Join Date: Mar 2009
Location: ATLANTA..DAWG country
Posts: 119
KDAWG97M3 is on a distinguished road
Quote:
Originally Posted by Qsilver7 View Post
The 4.8is only came with dual axle self leveling...so a quick diagram look up on realoem.com should give you the part number you need. The number you posted...when entered into the part number search pulls up the 4.6 is...since that model came with rear single axle only...that wouldn't work for the dual axle.

I used a 2006 4.8is with a 1/2006 build date to pull up the diagram: RealOEM.com - Online BMW Parts Catalog

If you click on the 11 digit part number at the link above...it will show the old part numbers that this latest number supersedes. So if your looking for used ones...those other 3 numbers would be the ones that are compatible.
Sorry I wasn't clear, but you answered my question and sorry I wasn't clear..thanks


Well I have a good working control module for sale?? 300.00 what I paid for it...
__________________
2013 X5 35D
2015 F350
2009 E90 M3
2007 GT3
1996 993 C4S
1991 964 Turbo
1994 D90
1989 E30 M3
1988 E30 M3
1972 cutlass supreme


-sold-
1993 E34 S52 supercharged wagon
1988 E30 M3 henna
2002 E46 M3
1997 E36 M3
2001 X5
2006 4.8is
1998 e36 M3 track car
1995 e36 M3 track car
Reply With Quote
  #18  
Old 03-29-2016, 07:43 AM
Member
 
Join Date: Mar 2009
Location: ATLANTA..DAWG country
Posts: 119
KDAWG97M3 is on a distinguished road
Ok, well I Took the pump apart and cleaned it. it lasted about 350 miles...now the light is back on. So I deal with it. Fast forward to last night. I went in VW Audi and bought a pump rebuild kit ( part number from a vendor) not a plug and play but should work..i take everything apart to put on the new kit..and get everything back in the car...now no power..I hook up my test light and test the plug that you plug the air pump into, and nothing. Check all three fuses ( 2 in back one in glove box) all fine, did I blow my control module? Why is there no power at the plug? Any help would be great. My shocks are holding air, and seem ok, but I am considering converting to coils and selling all of this shit, this has been a nightmare....blah

Thnaks for any help..
__________________
2013 X5 35D
2015 F350
2009 E90 M3
2007 GT3
1996 993 C4S
1991 964 Turbo
1994 D90
1989 E30 M3
1988 E30 M3
1972 cutlass supreme


-sold-
1993 E34 S52 supercharged wagon
1988 E30 M3 henna
2002 E46 M3
1997 E36 M3
2001 X5
2006 4.8is
1998 e36 M3 track car
1995 e36 M3 track car
Reply With Quote
  #19  
Old 03-29-2016, 10:23 AM
Awntchi's Avatar
Member
 
Join Date: Nov 2015
Location: Norway
Posts: 381
Awntchi is on a distinguished road
I converted mine even though I didn't have your type of issues....mine were easier to solve but just got sick of doing it all the time. Besides, doing the math, it would be A LOT cheaper to convert to standard suspension (in the long run). My 2 cents....your call

BMW X5 4.8iS 2005
__________________
BMW X5 E53, 4.8iS - 2005
Professional Stereo/Nav with DSP (modified BM54 module) - Converted to Eonon GA5166X with Reverse cam
4-Corner Air Suspension - Converted to BC Coilovers
Reply With Quote
  #20  
Old 03-29-2016, 10:34 PM
Member
 
Join Date: Mar 2009
Location: ATLANTA..DAWG country
Posts: 119
KDAWG97M3 is on a distinguished road
Quote:
Originally Posted by Awntchi View Post
I converted mine even though I didn't have your type of issues....mine were easier to solve but just got sick of doing it all the time. Besides, doing the math, it would be A LOT cheaper to convert to standard suspension (in the long run). My 2 cents....your call

BMW X5 4.8iS 2005
Honestly I want to sell the X5. I just picked up a E55 AMG WAGON and love it..the X5 was fun but this air shit has really driven me nuts..I know I am mad right now but stillll..

Let me know if there is something I can check to get this fixed...thanks
__________________
2013 X5 35D
2015 F350
2009 E90 M3
2007 GT3
1996 993 C4S
1991 964 Turbo
1994 D90
1989 E30 M3
1988 E30 M3
1972 cutlass supreme


-sold-
1993 E34 S52 supercharged wagon
1988 E30 M3 henna
2002 E46 M3
1997 E36 M3
2001 X5
2006 4.8is
1998 e36 M3 track car
1995 e36 M3 track car
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 07:20 PM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.