Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E53) Forum
Arnott
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-15-2018, 01:14 PM
Member
 
Join Date: Nov 2005
Location: Palm Coast, FL
Posts: 312
Bmwtvboy is on a distinguished road
Climate Control Broken?

How many of you had to replace your climate control center piece when you started blowing the 7.5 amp fuse? At my wits end.
Issue: Checked out a/c and it worked great, ice cold no issues running it straight out at 60 degrees. It's FL after all. Then when the weather cooled down an attempt to raise the temp up to 76 blew four fuses in a row. Now I have hot air only. I disconnected the unit.
I replaced the dual water heater valve with new one. Old one jammed up, so I figured that was the electrical issue.
I connect the c.c in sections, and as soon as I connect the power source and try to change the temp, poof, blows the 7.5 amp fuse.
I also cleaned the c.c. unit before connecting.
What am I missing? Is this a worthless c.c unit? Oddly, the rear fan console blows with the disconnected c.c. unit and none of the dash fan/air blows. Weird.
Thanks for your assistance.
__________________
X5 3.0 AUTO -2001 - 238,000 miles
Reply With Quote

Sponsored Links

  #2  
Old 12-15-2018, 01:19 PM
Gregory891's Avatar
Member
 
Join Date: Dec 2011
Location: Switzerland
Posts: 449
Gregory891 is on a distinguished road
Are your controls manual (knobs that you rotate) or automatic (digital display)? If automatic and given the age of the car and no fan blowing symptoms - it might be a VERY good idea to replace the final stage resistor (if you have automatic controls) - use a genuine part (Best) or Behr/Valeo, anything else doesn't last.
__________________
2002 Euro X5 (E53) 3.0 diesel (M57)
5 speed manual with UUC short shifter.
Pre-xDrive NV125 transfer case (chain & gears).
Factory Xenon headlights, Spyder LED tail lights
Updated vortex crankcase breather.
Motorsport dead pedal, factory fire extinguisher, factory first aid kit, factory F&R mud flaps, factory PDC

Bilstein B6 shocks F&R
Redline oil has replaced "lifetime" fluids (F&R diff, manual transmission, transfer case and P/S).
Dimple magnetic drain plugs in all compartments.
Reply With Quote
  #3  
Old 12-15-2018, 01:57 PM
Member
 
Join Date: Nov 2005
Location: Palm Coast, FL
Posts: 312
Bmwtvboy is on a distinguished road
Sorry, it's the dual automatic climate control panel. At about 150K miles I did replace the FSR, but at that time I did have the classic fan blower fluctuation issues. I will get one to replace it. I also have to test all my leads to the unit. Thanks man.
__________________
X5 3.0 AUTO -2001 - 238,000 miles
Reply With Quote
  #4  
Old 12-15-2018, 02:30 PM
andrewwynn's Avatar
Member
 
Join Date: Jun 2015
Location: Racine, WI
Posts: 3,735
andrewwynn is on a distinguished road
A good scanner can run each component separately. Eg blower at 50%, each flap motor (feet/dash/defrost). I would suspect the porcupine or the part you replaced (or wiring to it).

If only blows the fuse when demanding heat the logical defect is the hot water valve. Unplug the power to that and see if the fuse still blows (or measure Ω to it)
__________________
E53 / M54 2001 3.0i gas LHD (pair of them: his & her)
Reply With Quote
  #5  
Old 12-17-2018, 03:25 PM
Member
 
Join Date: Nov 2005
Location: Palm Coast, FL
Posts: 312
Bmwtvboy is on a distinguished road
That is a great idea. But, it still blew the fuse as soon as I connected the three line main power source. I need to do some electric diagnostic. New to me, so I'll tread carefully. Thanks again.
__________________
X5 3.0 AUTO -2001 - 238,000 miles
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 07:50 AM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.