Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E53) Forum
Bimmer Tool Rental
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-26-2019, 11:57 PM
Member
 
Join Date: Feb 2019
Location: Cleveland ohio
Posts: 7
llawes is on a distinguished road
Question has anyone ever fixed P1343

hello everyone!
bought 2 x5s this month
1 is a 2006 v8 with no issues !!
the other is a clean 2003 3.0 with a p1343 code
(misfire cylinder 1 with fuel cut off) and very rough running until i unplug the maf then i get full power restored and drives like a dream with a slight rough idle. also with the maf unplugged the p1343 is gone and replaced with the P0102 (maf circuit low)...
so far I've only changed plugs swapped coils(misfire stays with cyl 1)


has anyone ever experienced this or better yet solved a similar situation?
thanks.
Reply With Quote

Sponsored Links

  #2  
Old 02-27-2019, 12:16 PM
andrewwynn's Avatar
Member
 
Join Date: Jun 2015
Location: Racine, WI
Posts: 4,641
andrewwynn is on a distinguished road
Leakdown test can determine if you are having a mechanical or electrical problem.

My wife's car has been rough starting a few times and once in a while also same type of code. I replaced a coil when it repeated a particular cylinder but then moved to a different cylinder.

I'm suspecting either weak fuel pump (original with 170,000 miles it's definitely past it's expected life span) or dirty injectors. Somebody else on the forum just posted that some techron cleared his misfire/cutoff problem.
__________________
E53 / M54 2001 3.0i gas LHD (pair of them: his & her)
Reply With Quote
  #3  
Old 02-27-2019, 12:18 PM
andrewwynn's Avatar
Member
 
Join Date: Jun 2015
Location: Racine, WI
Posts: 4,641
andrewwynn is on a distinguished road
Keep a method to reset the code you don't even have to stop. I have a WiFi dongle I plug in a and use my phone. I can pull the car out of limp mode and keep on truckin'
__________________
E53 / M54 2001 3.0i gas LHD (pair of them: his & her)
Reply With Quote
  #4  
Old 02-27-2019, 12:42 PM
Member
 
Join Date: Feb 2019
Location: Cleveland ohio
Posts: 7
llawes is on a distinguished road
i did the reset thing but when you stop at a light or stop sign the cel comes on and loss of power
its runs great with the maf disconnected so thats how ive been driving it.
im gonna keep it parked for now until i get it together.

thanks for the replies
Reply With Quote
  #5  
Old 02-27-2019, 01:18 PM
andrewwynn's Avatar
Member
 
Join Date: Jun 2015
Location: Racine, WI
Posts: 4,641
andrewwynn is on a distinguished road
has anyone ever fixed P1343

Usually MAF disconnect will error on the side of rich. What does your fuel trim show when running with MAF? You could simply need new pre cat sensors.

Other options include disa valve. If it's not working properly it will disrupt proper airflow to the intake.
__________________
E53 / M54 2001 3.0i gas LHD (pair of them: his & her)
Reply With Quote
  #6  
Old 02-27-2019, 01:37 PM
Member
 
Join Date: Feb 2019
Location: Cleveland ohio
Posts: 7
llawes is on a distinguished road
not sure about fuel trim data, with the maf unplugged i only get the p0102 due to the maf being disconnected, wouldnt bad 02 set a code? it seems the maf is feeding bad data causing the misfire cyl 1 i get with maf plugged in..
i got it so cheap to be honest i could drive it like this but its clean and it deserves to run right!!

got my wife a 2006 4.4 she parked her 2014 cruze........
Reply With Quote
  #7  
Old 02-27-2019, 01:43 PM
andrewwynn's Avatar
Member
 
Join Date: Jun 2015
Location: Racine, WI
Posts: 4,641
andrewwynn is on a distinguished road
has anyone ever fixed P1343

Worn out O2 just sends the wrong data to the computer. If it reads low or high the computer will send too much or too little gas to the cylinder.

If unplugging MAF makes it run smoothly then actually that's the prime suspect. Did I just read you have two X5? If the 8 uses the same MAF swap them. Also clean them with MAF cleaner.

The code you are getting is a catch all misfire code. A bad detonation too many times in a minute will cause the car to disable that cylinder.

Another thought: when I first bought my X5, it would stall when I came to a stop and it turned out to be the CPS (cam position sensor). Very reasonable fix bought OE part for under $100 via Amazon.

I never got any error related to CPS just generic cylinder misfire/fuel cut off when my CPS failed. It "soft failed" just didn't output reliable data.

Never use other hand OE/OEM CPS or MAF.
__________________
E53 / M54 2001 3.0i gas LHD (pair of them: his & her)
Reply With Quote
  #8  
Old 02-27-2019, 01:53 PM
Member
 
Join Date: Feb 2019
Location: Cleveland ohio
Posts: 7
llawes is on a distinguished road
thanks for the info i will look into getting a new cps among other things.
and yes 2 x5's ill see it the mafs are compatible. update later when i get in.
Reply With Quote
  #9  
Old 02-27-2019, 01:55 PM
andrewwynn's Avatar
Member
 
Join Date: Jun 2015
Location: Racine, WI
Posts: 4,641
andrewwynn is on a distinguished road
Here's some added info: I was having some wonkines that could be coming from MAF I swapped with wife and only after she started getting the cylinder fuel cut off errors.


Sent from my iPhone using Tapatalk Pro
__________________
E53 / M54 2001 3.0i gas LHD (pair of them: his & her)
Reply With Quote
  #10  
Old 02-27-2019, 03:43 PM
Member
 
Join Date: Feb 2019
Location: Cleveland ohio
Posts: 7
llawes is on a distinguished road
So she got misfire with fuel cut with your suspect maf?
Reply With Quote
Reply

Bookmarks

Tags
ccv, injector, maf, misfire, vacuum leak

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 04:04 PM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.