Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E53) Forum
Fluid Motor Union
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #11  
Old 03-22-2020, 07:35 AM
Overboost's Avatar
//Binary is in my DNA
 
Join Date: Apr 2006
Location: Huntersville, NC
Posts: 2,714
Overboost is on a distinguished road
Quote:
Originally Posted by Patriks7 View Post
I have been reading a few more threads on this topic and want to see if my understanding is correct:

If I want to connect an Android stereo to my DSP equipped X5, I will need the iBus connector and license. But, if I am NOT planning on hooking up the stock navigation to the new stereo (since from what I saw they all come with their own GPS module and I will be using other apps anyway), will I be able to hook it up without the 6m harness going into the truck? As in, is it a plug-and-play in the front?
If you have the factory navigation (that you are removing), you will need to run the harness to the rear to connect to the wiring needed. The only plug and play up front is for non factory navigation equipped cars.
Reply With Quote

Sponsored Links

  #12  
Old 03-22-2020, 07:49 AM
Member
 
Join Date: Dec 2014
Location: Vienna, Austria
Posts: 87
Patriks7 is on a distinguished road
Quote:
Originally Posted by Overboost View Post
If you have the factory navigation (that you are removing), you will need to run the harness to the rear to connect to the wiring needed. The only plug and play up front is for non factory navigation equipped cars.
Alright, I did misunderstand then! Looks like I have my work cutout for me then.

Also a question for you or anyone else, any experience with installing a wireless phone charging pad somewhere? I currently have a cradle, but I think that will be unnecessary with the new stereo.
__________________
03.06 BMW X5 4.8is LeMans Blue
Reply With Quote
  #13  
Old 03-23-2020, 07:55 PM
Quicksilver's Avatar
Premier Member and retired relic
 
Join Date: Mar 2005
Location: NORCAL
Posts: 17,176
Quicksilver will become famous soon enough
Probably already answered but why not get the one you have refreshed?
__________________
"What you hear in a great jazz band is the sound of democracy. “The jazz band works best when participation is shaped by intelligent communication.”
Harmony happens whenever different parts get to form a whole by means of congruity, concord, symetry, consistency, conformity, correspondence, agreement, accord, unity, consonance…….
Reply With Quote
  #14  
Old 04-20-2020, 02:06 PM
Member
 
Join Date: Dec 2014
Location: Vienna, Austria
Posts: 87
Patriks7 is on a distinguished road
Update:

Help!

After a lot of research, I ended up going for an Xtrons model, which the very kind and helpful customer service assured would work with my model with a separate cable. It arrived about 2 weeks ago, but I haven't had time to look into it until today. I decided to follow the installation of Crowz, which was very helpful, but upon connecting every cable as is indicated, the stereo does not turn on. Nothing, not even a blink.

I tried to troubleshoot every connection, but could not come up with anything. Any ideas or suggestions or similar experiences?
__________________
03.06 BMW X5 4.8is LeMans Blue
Reply With Quote
  #15  
Old 04-20-2020, 08:00 PM
Member
 
Join Date: May 2019
Location: florida
Posts: 168
tmat1977 is on a distinguished road
please make sure you solder the connections with the ibus or it wont send signal. that was with my case i have an eonon ga9166a head unit with ibus
i had busines radio with cd player with dsp


take a look at what i have
https://www.youtube.com/watch?v=W3XOwNBQTUc


https://shop.ibus-app.de/en/shop/

you will need usb device app and lic
Reply With Quote
  #16  
Old 04-20-2020, 10:53 PM
blackknight530i's Avatar
Swap Addict
 
Join Date: May 2014
Location: Charlotte, NC
Posts: 16
blackknight530i is on a distinguished road
Just for future reference for people who don't know, to make an aftermarket radio work with the DSP amp, all you need to do is code the DSP amp to mid_basis instead of bord_monitor. It will no longer shut off the sound after a few seconds. Also, you can wire up a DSP MID (bought from a salvage yard or ebay) to ibus, power and ground and be able to set the DSP settings, then disconnect it once set. Use the high powered front left and right speaker outputs to the DSP amp inputs from the radio module and fix the audio level on the head unit, then use the steering wheel controls to control volume.

This works great in my 4.8is with a Pioneer AVIC-6200NEX head unit. It should also allow any of the non-DSP, non-Android head units to work with DSP amps (Dynavin and other ones that fit the space, but don't have a "DSP" module). It also works with my NBT system in both of my e39s with DSP.
Reply With Quote
  #17  
Old 04-20-2020, 11:04 PM
Overboost's Avatar
//Binary is in my DNA
 
Join Date: Apr 2006
Location: Huntersville, NC
Posts: 2,714
Overboost is on a distinguished road
Quote:
Originally Posted by blackknight530i View Post
Just for future reference for people who don't know, to make an aftermarket radio work with the DSP amp, all you need to do is code the DSP amp to mid_basis instead of bord_monitor. It will no longer shut off the sound after a few seconds. Also, you can wire up a DSP MID (bought from a salvage yard or ebay) to ibus, power and ground and be able to set the DSP settings, then disconnect it once set. Use the high powered front left and right speaker outputs to the DSP amp inputs from the radio module and fix the audio level on the head unit, then use the steering wheel controls to control volume.

This works great in my 4.8is with a Pioneer AVIC-6200NEX head unit. It should also allow any of the non-DSP, non-Android head units to work with DSP amps (Dynavin and other ones that fit the space, but don't have a "DSP" module). It also works with my NBT system in both of my e39s with DSP.
Certainaly a lot of debate on this one. My X5 came with a mid, not nav and the DSP module was set to mid_basis and once I installed the Avin Avant-4 with the iBus adapter before adding the app, the sound was dead. Once the app was added to the Android system and sent the DSP message, the sound was there.
Reply With Quote
  #18  
Old 04-20-2020, 11:09 PM
blackknight530i's Avatar
Swap Addict
 
Join Date: May 2014
Location: Charlotte, NC
Posts: 16
blackknight530i is on a distinguished road
Quote:
Originally Posted by Overboost View Post
Certainaly a lot of debate on this one. My X5 came with a mid, not nav and the DSP module was set to mid_basis and once I installed the Avin Avant-4 before adding the app, the sound was dead. Once the app was added to the Android system and sent the DSP message, the sound was there.
Well, are you sure it was mid_basis and not front_mid? They are different. I know that it works well on both my NBT systems and my Pioneer aftermarket system with that being the only change. Might need to do it on the cluster as well. Been a while and I haven't checked to see if I did it in the cluster as well or not.
__________________

-Paul
2003 "M5" - Full M5 conversion, GC Coilovers, Eibach ARBs, UUC Evo3/DSSR, Borla Exhaust w/Muffler Delete, BMW NBT, Bi-Xenons, APEX PS-7s, e60 Hubs
2004 X5 4.8is - Stock for now
2005 Range Rover (M62TU Powered) - Getting 4.6is engine swap
Reply With Quote
  #19  
Old 04-20-2020, 11:13 PM
blackknight530i's Avatar
Swap Addict
 
Join Date: May 2014
Location: Charlotte, NC
Posts: 16
blackknight530i is on a distinguished road
Also, just noticed you're in Huntersville. You're less than 10 miles from me. I'm in North Charlotte off of Sunset Rd and I77.
__________________

-Paul
2003 "M5" - Full M5 conversion, GC Coilovers, Eibach ARBs, UUC Evo3/DSSR, Borla Exhaust w/Muffler Delete, BMW NBT, Bi-Xenons, APEX PS-7s, e60 Hubs
2004 X5 4.8is - Stock for now
2005 Range Rover (M62TU Powered) - Getting 4.6is engine swap
Reply With Quote
  #20  
Old 04-20-2020, 11:16 PM
Overboost's Avatar
//Binary is in my DNA
 
Join Date: Apr 2006
Location: Huntersville, NC
Posts: 2,714
Overboost is on a distinguished road
Almost certain it was mid_basis but I will check next time I plug in NCS Expert. I looked for a saved DSP trace file but must have not saved it on my laptop.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 04:45 AM.
vBulletin, Copyright 2020, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
© 2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.