Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E53) Forum
Fluid Motor Union
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-24-2020, 01:33 PM
EODguy's Avatar
Member
 
Join Date: Jun 2018
Location: Saudi Arabia/Philippines/USA
Posts: 1,261
EODguy is on a distinguished road
Another chain of crap...

Today I got a "check num plate light" message on shutdown, I looked and all lights were good.

Upon starting the X sounded rough and had cylinder 4 misfire and low MAF output (1.2) so after clearing codes no misfire ran fine but MAF stuck at low output (4.7) and no increase in flow EVER

I know many on here don't believe in the weirdo chain of crap, but it is the same shit I went through before and that time I ended up buying a MAF from the stealership @ 1800 SAR or 480 USD...

So either I have another bad MAF or I have some secret ninja short killed cylinder 4, MAF and making the LCM give a BS reading

I am leaning towards the latter and I hope that someone here has an idea of where a short could be that would effect all 3 of these. Maybe where there is a junction of all wires that could short between due to proximity?

Bueller, Bueller....

Sent from my SM-A730F using Tapatalk
__________________
"When the Team Chief said.... You're trapped in a hole with nothing but a goat and a slinky, what do you do? Stubby said, I'm not sure but it won't end well for the goat...." ~(Overheard) Last day, Phase 3, Q Course
Reply With Quote

Sponsored Links

  #2  
Old 03-24-2020, 01:43 PM
Overboost's Avatar
//Binary is in my DNA
 
Join Date: Apr 2006
Location: Huntersville, NC
Posts: 2,538
Overboost is on a distinguished road
When it rains it pours. That sucks. Maybe disconnect the MAF and see if you have the same 4.7 g/s reading. Check all the terminals at the MAF and where they end up at the DME and see if any are spread or corroded.
Reply With Quote
  #3  
Old 03-24-2020, 01:43 PM
crystalworks's Avatar
Member
 
Join Date: Jun 2014
Location: SA, TX
Posts: 4,510
crystalworks is on a distinguished road
You've had a fight on your hands with that truck. I think I would start with the IVM, battery, and then alternator with my troubleshooting. Doesn't cost anything to check them.

IVM or why my engine runs sluggish??? N62 applies to ALL cars with it. E53/e65/e60/e63/e64/e66 | BMW LOGIC7

Edit: How old is that MAF?
__________________
2005 X5 4.4i Build 04/05 Maintenance/Build Log
Nav, Pano, Sport (Purchased 06/14 w/ 109,000 miles) (Sold 8/15 w/121,000 miles)


2006 X5 4.8is Build 11/05 Maintenance/Build Log
Nav, DSP, Pano, Running Boards, OEM Tow Hitch, Cold Weather Pckg (Purchased 08/15 w/ 90,500 miles)

2010 X5 35d Build 02/10
Nav, HiFi, 6 DVD, Sports Pckg, Cold Weather Pckg, HUD, CAS, Running Boards, Leather Dash, PDC, Pano (Purchased 03/17 w/ 136,120 miles)
Reply With Quote
  #4  
Old 03-24-2020, 01:46 PM
EODguy's Avatar
Member
 
Join Date: Jun 2018
Location: Saudi Arabia/Philippines/USA
Posts: 1,261
EODguy is on a distinguished road
Thanks guys I'll be on it tomorrow until it "accidentally" blows up in the parking lot while I stand there crying about all the Picasso paintings in the back seat to the insurance company....

Sent from my SM-A730F using Tapatalk
__________________
"When the Team Chief said.... You're trapped in a hole with nothing but a goat and a slinky, what do you do? Stubby said, I'm not sure but it won't end well for the goat...." ~(Overheard) Last day, Phase 3, Q Course
Reply With Quote
  #5  
Old 03-24-2020, 02:46 PM
crystalworks's Avatar
Member
 
Join Date: Jun 2014
Location: SA, TX
Posts: 4,510
crystalworks is on a distinguished road
Picasso is too obvious. Use Renoir or something.

OB is probably more on point than charging system components but I always like to make sure they are in good shape. If that MAF is less than 2 years old though I'd hesitate to think it's faulty. Reminds me I need to check my IVM.
__________________
2005 X5 4.4i Build 04/05 Maintenance/Build Log
Nav, Pano, Sport (Purchased 06/14 w/ 109,000 miles) (Sold 8/15 w/121,000 miles)


2006 X5 4.8is Build 11/05 Maintenance/Build Log
Nav, DSP, Pano, Running Boards, OEM Tow Hitch, Cold Weather Pckg (Purchased 08/15 w/ 90,500 miles)

2010 X5 35d Build 02/10
Nav, HiFi, 6 DVD, Sports Pckg, Cold Weather Pckg, HUD, CAS, Running Boards, Leather Dash, PDC, Pano (Purchased 03/17 w/ 136,120 miles)
Reply With Quote
  #6  
Old 03-24-2020, 11:25 PM
andrewwynn's Avatar
Member
 
Join Date: Jun 2015
Location: Racine, WI
Posts: 5,837
andrewwynn is on a distinguished road
Ever watch the movie throw mama from the train?
__________________
E53 / M54 2001 3.0i gas LHD (pair of them: his & her)
Reply With Quote
  #7  
Old 03-25-2020, 04:26 AM
EODguy's Avatar
Member
 
Join Date: Jun 2018
Location: Saudi Arabia/Philippines/USA
Posts: 1,261
EODguy is on a distinguished road
Quote:
Originally Posted by andrewwynn View Post
Ever watch the movie throw mama from the train?
Yes I have but I am thinking about a remake called "Throw the BMW engineer from the train" and even if it's not a boxoffice hit, I would enjoy the shit out of it

Sent from my SM-A730F using Tapatalk
__________________
"When the Team Chief said.... You're trapped in a hole with nothing but a goat and a slinky, what do you do? Stubby said, I'm not sure but it won't end well for the goat...." ~(Overheard) Last day, Phase 3, Q Course
Reply With Quote
  #8  
Old 03-28-2020, 12:23 PM
EODguy's Avatar
Member
 
Join Date: Jun 2018
Location: Saudi Arabia/Philippines/USA
Posts: 1,261
EODguy is on a distinguished road
Update...

Upstream bank two O2 is dead now so replacement is here tomorrow

Still haven't figured anything out but since I run Torque Pro real time anft doing a quick clear from it MAF numbers go up... i.e. 1.0 to 2.7 and so on but only able to get to 6.4, I have also noticed that my head unit stays connected to my OBD2 dongle via BT but is now greyed out and won't pair to anything else even if dongle is unpaired.

Is it possible that something is causing a "hang" in the clear code function and sticking the winnie to the bus making a MAF failure?

Sent from my SM-A730F using Tapatalk
__________________
"When the Team Chief said.... You're trapped in a hole with nothing but a goat and a slinky, what do you do? Stubby said, I'm not sure but it won't end well for the goat...." ~(Overheard) Last day, Phase 3, Q Course
Reply With Quote
  #9  
Old 04-09-2020, 09:22 AM
EODguy's Avatar
Member
 
Join Date: Jun 2018
Location: Saudi Arabia/Philippines/USA
Posts: 1,261
EODguy is on a distinguished road
Another update....

I am now getting a implausible air intake temp (without temp showing in data)...

WTAF!!!
On the bright side my brakes worked super well as I was doing 140 in an 80 zone and came upon a police checkpoint

Came to a stop next to 4 cops/2 squad cars, rolled the window down and asked "is there a problem officer?" all with a shit eating grin and hoping nobody spoke English

Sent from my SM-A730F using Tapatalk
__________________
"When the Team Chief said.... You're trapped in a hole with nothing but a goat and a slinky, what do you do? Stubby said, I'm not sure but it won't end well for the goat...." ~(Overheard) Last day, Phase 3, Q Course
Reply With Quote
  #10  
Old 04-09-2020, 11:55 AM
crystalworks's Avatar
Member
 
Join Date: Jun 2014
Location: SA, TX
Posts: 4,510
crystalworks is on a distinguished road
Stop posting these updates! My truck must be reading it. Current list: front air suspension won't hold air, alternator housing gasket leak started, front right axle clicking, valve cover gasket leak, and a slow leak in passenger rear tire (screw).
__________________
2005 X5 4.4i Build 04/05 Maintenance/Build Log
Nav, Pano, Sport (Purchased 06/14 w/ 109,000 miles) (Sold 8/15 w/121,000 miles)


2006 X5 4.8is Build 11/05 Maintenance/Build Log
Nav, DSP, Pano, Running Boards, OEM Tow Hitch, Cold Weather Pckg (Purchased 08/15 w/ 90,500 miles)

2010 X5 35d Build 02/10
Nav, HiFi, 6 DVD, Sports Pckg, Cold Weather Pckg, HUD, CAS, Running Boards, Leather Dash, PDC, Pano (Purchased 03/17 w/ 136,120 miles)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 08:01 PM.
vBulletin, Copyright 2020, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.