Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E53) Forum
Arnott
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-07-2022, 08:25 PM
Member
 
Join Date: Aug 2021
Location: Ooltewah, TN
Posts: 90
TheFixer is on a distinguished road
Wierd seat issue....

When I put in nicer seats in a while ago the heated seats would not work. Insta showed that the SZM module wasn't getting can signal. I'm like, whatever. I'll deal with it later.

Anyway, noticed on our recent road trip that when there's a passenger in the passenger seat the heated seats work. Or even if I just put light pressure anywhere on the seat with my finger the heated seats work.

It's also vice versa. I have to be in the driver's seat because when my wife is in the passenger side and I get out, the heated seats will turn off.

So, there's something odd going on with the seat pads.

Anyone else have this issue?
Reply With Quote

Sponsored Links

  #2  
Old 01-07-2022, 09:23 PM
Member
 
Join Date: Apr 2019
Location: Boston, MA
Posts: 520
Effduration is on a distinguished road
I haven't ever read anything like this on any of the forums, and certainly have not experienced.

It sounds like the pressure sensor in the seat that activates the seat belt chime if you don't fasten your (or your passenger's if occupied) seat belt is somehow crossed with the seat heater.

Should a seat heater in an E53 X5 turn on if the seat is not occupied? I don't know
Reply With Quote
  #3  
Old 01-07-2022, 10:14 PM
Member
 
Join Date: Aug 2021
Location: Ooltewah, TN
Posts: 90
TheFixer is on a distinguished road
I'm sure I'll figure it out. It's just very odd.

I'll dig into with ista when I get the chance.
Reply With Quote
  #4  
Old 01-08-2022, 09:36 AM
Member
 
Join Date: Jun 2021
Location: Austin, TX
Posts: 426
X5chemist is on a distinguished road
Is it a safety feature? Do heated seats turn off to prevent possible damage? Now, I'm curious. Both front seats on mine work independently. Next time I drive it, I'll turn on an empty passenger seat.
__________________
'06 X5 3.0i - bought @143,123 miles (12/26/20)
Reply With Quote
  #5  
Old 01-08-2022, 09:53 AM
Member
 
Join Date: Aug 2021
Location: Ooltewah, TN
Posts: 90
TheFixer is on a distinguished road
That wouldn't be a problem if one seat didn't work because no one is sitting in it. Problem is neither works unless both seats have someone or something in them at the same time.
Reply With Quote
  #6  
Old 01-08-2022, 11:43 AM
Member
 
Join Date: Mar 2019
Location: Atlanta GA
Posts: 87
nextelbuddy is on a distinguished road
I had this same exact problem. I installed e53 sport seats into my 06 4.8is... the comfort sets used of3 srs seat pad and the sport seats used oc2.

I had the srs plug plugged in on passenger side and that was Causing the issue. I had to unplug the srs seat pad passenger seat under neath... You will get an srs light bit your heated seats should work. Then you just code out the passenger seat occupancy sensor in the srs module.

Coding it out as leaving it plugged in doesn't work either as you will get a srs seat occupancy plausibility error .

It has to be unplugged and coded out.
Reply With Quote
  #7  
Old 01-08-2022, 12:52 PM
Member
 
Join Date: Aug 2021
Location: Ooltewah, TN
Posts: 90
TheFixer is on a distinguished road
Quote:
Originally Posted by nextelbuddy View Post
I had this same exact problem. I installed e53 sport seats into my 06 4.8is... the comfort sets used of3 srs seat pad and the sport seats used oc2.

I had the srs plug plugged in on passenger side and that was Causing the issue. I had to unplug the srs seat pad passenger seat under neath... You will get an srs light bit your heated seats should work. Then you just code out the passenger seat occupancy sensor in the srs module.

Coding it out as leaving it plugged in doesn't work either as you will get a srs seat occupancy plausibility error .

It has to be unplugged and coded out.

Thanks for that info! Very helpful.

I was thinking it might be something like that. I will play with coding some more and see if that is the case with these seats.

I have insta p, so I think I can update the configuration with that so I can have it work properly without disabling the occupancy sensor.

What's weird to me is I can't understand why it screws with the bus.... well, I kinda do. All connected, so when one thing is screwy other things affected.

What I really need to do is get in depth reading how the bus system functions.
Reply With Quote
  #8  
Old 01-08-2022, 01:05 PM
Member
 
Join Date: Mar 2019
Location: Atlanta GA
Posts: 87
nextelbuddy is on a distinguished road
What kind of seats did you install and what year car were they from? Did you also have a newer X5 with the comfort seats and the OC3 seat mats?
Reply With Quote
  #9  
Old 01-08-2022, 01:40 PM
Member
 
Join Date: Aug 2021
Location: Ooltewah, TN
Posts: 90
TheFixer is on a distinguished road
Quote:
Originally Posted by nextelbuddy View Post
What kind of seats did you install and what year car were they from? Did you also have a newer X5 with the comfort seats and the OC3 seat mats?
I have an 06 e53 3.0i. Was super basic. Hadc vinyl cheap seats. I put leather in from an 04 4.8i sport model. So, it's likely the pads are indeed different.
Reply With Quote
  #10  
Old 01-09-2022, 08:39 AM
Member
 
Join Date: Apr 2019
Location: Boston, MA
Posts: 520
Effduration is on a distinguished road
Quote:
Originally Posted by TheFixer View Post
I have an 06 e53 3.0i. Was super basic. Hadc vinyl cheap seats. I put leather in from an 04 4.8i sport model. So, it's likely the pads are indeed different.
Those '04 seats should swap right and work unless your '06 w/ vinyl didn't come with heated seats...

although I don't know what this OC3, 02D, OCD stuff everybody is talking about related to the seat pads..need to look that up...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 11:10 PM.
vBulletin, Copyright 2022, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.