Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E53) Forum
Fluid Motor Union
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-14-2009, 02:51 PM
Member
 
Join Date: Jul 2009
Location: west sussex
Posts: 6
daztc is on a distinguished road
X5 PDC

I have just purchased 3.0i x5 but the parking sensor both front and rear do not work....i get a continuous sound and flashing switch when resrve is selected...i assume its the main sensor switch...is there anyway of checking and where is the switch located?
Reply With Quote

Sponsored Links

  #2  
Old 07-14-2009, 04:12 PM
AZX54.4's Avatar
Member
 
Join Date: Jun 2009
Location: Phoenix,AZ
Posts: 456
AZX54.4 is on a distinguished road
This is not a problem with the switch. If the light on the PDC button is flashing there is a problem with the sensors. Check all of your sensors. This will happen if one of them is damaged or no longer working. If one is damaged or not working it will set the entire system off. Good Luck
Reply With Quote
  #3  
Old 07-14-2009, 04:14 PM
killcrap's Avatar
Member
 
Join Date: Mar 2009
Location: america
Posts: 1,474
killcrap is on a distinguished road
Quote:
Originally Posted by daztc View Post
I have just purchased 3.0i x5 but the parking sensor both front and rear do not work....i get a continuous sound and flashing switch when resrve is selected...i assume its the main sensor switch...is there anyway of checking and where is the switch located?
possible vehicle was in accident, and wiring was severed, read out fault memory, and see which one is not communcating with the pdc module
Reply With Quote
  #4  
Old 07-14-2009, 04:46 PM
Member
 
Join Date: May 2009
Location: Hertfordshire England
Posts: 45
Simon_0106 is on a distinguished road
Hi, I have a simular problem with my e39 but no flashing light does that mean that my pdc ecu is no good???? Any help would be appriciated. Thanks
Reply With Quote
  #5  
Old 07-14-2009, 04:56 PM
Member
 
Join Date: Oct 2006
Location: Chicago
Posts: 528
BimmerDude is on a distinguished road
I have the same problem. All you have to do is get real close to each sensor. You should hear a ticking sound if the sensor is working. When you find the one or more that do not tick, those are the sensors that need to be replaced. I found mine, but problem is that its the front left side. I have to drop the bumper to remove this sensor. Sucks, but there is no other way. Would anyone know another way to change this sensor without removing the front bumper? Thanks
Reply With Quote
  #6  
Old 07-14-2009, 05:59 PM
AZX54.4's Avatar
Member
 
Join Date: Jun 2009
Location: Phoenix,AZ
Posts: 456
AZX54.4 is on a distinguished road
Quote:
Originally Posted by BimmerDude View Post
I have the same problem. All you have to do is get real close to each sensor. You should hear a ticking sound if the sensor is working. When you find the one or more that do not tick, those are the sensors that need to be replaced. I found mine, but problem is that its the front left side. I have to drop the bumper to remove this sensor. Sucks, but there is no other way. Would anyone know another way to change this sensor without removing the front bumper? Thanks
I need to replace the front left corner PDC on my 05 X5. I believe you might be able to get to the PDC in the corner with out removing the bumper. I am going to try by removing front left wheel (for better access) and then remove the plastic wheel liner, pull that back and i think i should be able to reach the PDC. The new PDC is being shipped so when it arrives I will try this out and see if it works. I will post how it works out.

Has anyone else tried this method???
Reply With Quote
  #7  
Old 07-15-2009, 08:23 AM
Member
 
Join Date: Jul 2009
Location: west sussex
Posts: 6
daztc is on a distinguished road
Many thanks for all those suggestions....they are all helpful...have followed suggestion to check each sensor.....NONE of them appear to click....i have selected reverse and got close to each sensor...nothing! also selected first, nothing!....i read the handbook and it says "the system has developed a malfunction if the light flashes and a continuos bleep is emitted briefly" when you engage reverse fot the first time! and yes thats what is happening....
Reply With Quote
  #8  
Old 07-15-2009, 11:45 AM
pochiserna's Avatar
Member
 
Join Date: Mar 2009
Location: Austin, Tx
Posts: 41
pochiserna is on a distinguished road
Quote:
Originally Posted by AZX54.4 View Post
I need to replace the front left corner PDC on my 05 X5. I believe you might be able to get to the PDC in the corner with out removing the bumper. I am going to try by removing front left wheel (for better access) and then remove the plastic wheel liner, pull that back and i think i should be able to reach the PDC. The new PDC is being shipped so when it arrives I will try this out and see if it works. I will post how it works out.

Has anyone else tried this method???
I was thinking of doing the exact same thing but haven't had a chance. I also need to replace that front left sensor and the way you describe on doing it seems easier than taking off the bumper. Please let us know how it works out.
Reply With Quote
  #9  
Old 07-15-2009, 12:32 PM
AZX54.4's Avatar
Member
 
Join Date: Jun 2009
Location: Phoenix,AZ
Posts: 456
AZX54.4 is on a distinguished road
Quote:
Originally Posted by daztc View Post
Many thanks for all those suggestions....they are all helpful...have followed suggestion to check each sensor.....NONE of them appear to click....i have selected reverse and got close to each sensor...nothing! also selected first, nothing!....i read the handbook and it says "the system has developed a malfunction if the light flashes and a continuos bleep is emitted briefly" when you engage reverse fot the first time! and yes thats what is happening....
I have never been instructed to listen for a clicking noise from the outside to inspect the sensors.?? Are any of the sensors damaged, scratched etc.... This would cause a system failure.
Reply With Quote
  #10  
Old 07-15-2009, 12:39 PM
AZX54.4's Avatar
Member
 
Join Date: Jun 2009
Location: Phoenix,AZ
Posts: 456
AZX54.4 is on a distinguished road
Quote:
Originally Posted by pochiserna View Post
I was thinking of doing the exact same thing but haven't had a chance. I also need to replace that front left sensor and the way you describe on doing it seems easier than taking off the bumper. Please let us know how it works out.
@ pochiserna I ordered the PDC sensor from a company outside Sacramento, CA. Bavarian Auto Recycling Inc. They have an ebay store and sell many parts for our cars at a good price. I will keep you posted on if this method to replace the sensor works. The PDC will arrive tomorrow but I will be out of town for the weekend so it might not be until later next week that ill get a chance to install it. Either way ill keep you up to date on how i install the new PDC!!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 01:20 PM.
vBulletin, Copyright 2020, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.