Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E53) Forum
Arnott
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #21  
Old 05-19-2013, 03:30 PM
Daka's Avatar
Member
 
Join Date: Dec 2008
Location: Ft Lauderdale
Posts: 423
Daka is on a distinguished road
Once more, I think you may be mistaken about battery....I have the same light on, battery is fine, my indie shop shut it off with the computer, but it came back...and he tells me it is THE STEERING ANGLE SENSOR, ABOUT $450 TO CHANGE IT, LOCATED AT THE BOTTOM OF THE STEERING SHAFT UNDER THE DASH.
Also, when it is on you have NO ABS ??
__________________
BMWCCA # 12660
14 GLK 350 M/B (hatefull POS gone)
05 CLK 500 AMG Cabrio
07 530xiT
09 Boxster
Reply With Quote

Sponsored Links

  #22  
Old 05-19-2013, 04:28 PM
Qsilver7's Avatar
Member
 
Join Date: Oct 2012
Location: Indiana, USA
Posts: 3,346
Qsilver7 is on a distinguished road
Quote:
Originally Posted by Daka View Post
Once more, I think you may be mistaken about battery....I have the same light on, battery is fine, my indie shop shut it off with the computer, but it came back...and he tells me it is THE STEERING ANGLE SENSOR, ABOUT $450 TO CHANGE IT, LOCATED AT THE BOTTOM OF THE STEERING SHAFT UNDER THE DASH.
Also, when it is on you have NO ABS ??
Can you "qualify" as to what "fine" is? Is your battery voltage below 11.89 volts, too or does it remain above 12 volts? Knowing better what you mean by "fine" would be helpful in disqualifying low battery voltage as the culprit.

I believe I've read that some who have had this light illuminated and the steering angle sensor was causing the fault...some have turned the steering wheel from lock to lock (turn all the way counter clockwise, then all the way clockwise) and have gotten the light to go off.

But this is only if there's nothing critically wrong with the system other than a small electrical gremlin.
__________________
{BMW CCA Member #191509 - (for more info see: www.bmwcca.org)}
  • 2013 f06 650ix GC (1/13 build date) Black Sapphire exterior/Schwarz (black) Nappa Leather interior
  • 2006 e53 X5 4.4i (12/05 build date) Sterling Gray exterior/Schwarz (black) Dakota Leather interior
  • 1997 e38 740iL (sold) Arctic Silver
  • 1999 e39 540iT (sold) Orient Blue
  • 1995 e34 525iT (sold) Alpine White
  • 1991 e32 735iL (sold) Schwarz (black)
  • 1985 e30 325e (sold) Bronzit
Reply With Quote
  #23  
Old 05-19-2013, 10:05 PM
Member
 
Join Date: Jun 2012
Location: Cali
Posts: 111
ninjabmw is on a distinguished road
Quote:
Originally Posted by Qsilver7 View Post
Can you "qualify" as to what "fine" is? Is your battery voltage below 11.89 volts, too or does it remain above 12 volts? Knowing better what you mean by "fine" would be helpful in disqualifying low battery voltage as the culprit.

I believe I've read that some who have had this light illuminated and the steering angle sensor was causing the fault...some have turned the steering wheel from lock to lock (turn all the way counter clockwise, then all the way clockwise) and have gotten the light to go off.

But this is only if there's nothing critically wrong with the system other than a small electrical gremlin.
In my case i mean above 12 which means the battery is fine everything is functioning i have had this problem for a while just 4x4 on, i can turn it off but it comes back, and i know that i have to change the steering angle sensor which is $450. Hope that clarifies, this is in my case not his
Reply With Quote
  #24  
Old 05-20-2013, 08:54 AM
rogerkiu's Avatar
Member
 
Join Date: Oct 2005
Location: Hong Kong
Posts: 1,055
rogerkiu is on a distinguished road
I guess you might encounter alternator problem. You should have got over 14v when the engine is running if your alternator is working fine, however, you said it was only 13.x. I don't think it is the angle sensor, because you would have had all lights up including ABS, brake light and 4x4 light if your angle sensor goes wrong. Run a test on the alternator.
__________________
--2004 E53 X5 4.8is - ECE version; right hand drive; Located in Hong Kong; ext. black sapphire metallic; int. leather black; adaptive dynamic bi-xenon headlights; 16:9 onboard monitor w/o navigation; 20" genuine BMW Y-spoke 214 wheels with Bridgestone Dueler H/P Sport tires; Int. rear view mirror w/ compass.
Reply With Quote
  #25  
Old 05-20-2013, 10:15 AM
Daka's Avatar
Member
 
Join Date: Dec 2008
Location: Ft Lauderdale
Posts: 423
Daka is on a distinguished road
Quote:
Originally Posted by ninjabmw View Post
In my case i mean above 12 which means the battery is fine everything is functioning i have had this problem for a while just 4x4 on, i can turn it off but it comes back, and i know that i have to change the steering angle sensor which is $450. Hope that clarifies, this is in my case not his
I have 12 volts engine off and 13.75 running.

My light went off the first time when I did the wheel lock to wheel lock, but came back on, the my indie cleared it and it came back on again....

So what else can cause the indicator, and hopefully the steering angle sensor change will fix it....I'm a bit PISSSED at BMW with the $4-500 repairs now and then on a car with 58,000 miles

And since the STEALERS are such F*****S with their selling tactics, I'll bite the bullet and jusk keep this car.
I think I get irrational about trading up and getting a newer one, our 06 is GREAT, even though it needs "massaging" now and then
We put about 8K miles a year on it, so when it is 10 years old annd the depreciation has leveled off, MAYBE I'll look at upgrading
For now the local BMW dealers can kiss my ass.......
VISTA AND FT LAUDERDALE BMW
__________________
BMWCCA # 12660
14 GLK 350 M/B (hatefull POS gone)
05 CLK 500 AMG Cabrio
07 530xiT
09 Boxster
Reply With Quote
  #26  
Old 05-20-2013, 11:45 AM
Member
 
Join Date: May 2013
Location: Colorado
Posts: 55
Buguyed is on a distinguished road
Quote:
Originally Posted by Daka View Post
Once more, I think you may be mistaken about battery....I have the same light on, battery is fine, my indie shop shut it off with the computer, but it came back...and he tells me it is THE STEERING ANGLE SENSOR, ABOUT $450 TO CHANGE IT, LOCATED AT THE BOTTOM OF THE STEERING SHAFT UNDER THE DASH.
Also, when it is on you have NO ABS ??
I took the X5 out to a dirt road this weekend to test this. ABS works as good as ever Does that change anything?
__________________
2004 E46 M3 Silbergrau - Mein
2004 E53 3.0i TiAG - Wife's
2002 E46 330i TiAG - Sold
1999 E46 328i Schwarz - Sold
1961 VW Beetle GolfBlau Ragtop Sdn - Mein
Reply With Quote
  #27  
Old 05-20-2013, 11:52 AM
Member
 
Join Date: May 2013
Location: Colorado
Posts: 55
Buguyed is on a distinguished road
Quote:
Originally Posted by Qsilver7 View Post
Before ruling out low battery voltage (since your new battery is also below 0% state of charge)...if you have a battery charger...hook it up to the jump start terminals in the engine bay. Give your new battery a good long recharge like 2 amps for approx 20 hours, or 10 amps at approx 8 hours.

Also make sure that all the battery cells are sufficiently filled with electrolyte (distiller water).
Sunday I checked fluids on new battery, all is good. Then Unplugged the battery for 1.5 hours to hopefully reset anything. Then hooked all back up.
I don't have a battery charger so got some jumper cables and ran from my E46 (Has 13.6 volts off and 14.2 running) to the E53. With cables in place and the X off, it was getting 13.4 volts at the OBC. Running it was at 13.8. Did this for about 30 ish minutes. (I ran cables to connector under the hood and not battery direct).
Afterwards I tried the steering wheel turn lock to lock a couple times and went for a drive. Seeing 13.8 on the OBC the entire drive. Light still present as ever...
__________________
2004 E46 M3 Silbergrau - Mein
2004 E53 3.0i TiAG - Wife's
2002 E46 330i TiAG - Sold
1999 E46 328i Schwarz - Sold
1961 VW Beetle GolfBlau Ragtop Sdn - Mein
Reply With Quote
  #28  
Old 05-20-2013, 11:54 AM
Member
 
Join Date: May 2013
Location: Colorado
Posts: 55
Buguyed is on a distinguished road
Quote:
Originally Posted by rogerkiu View Post
I guess you might encounter alternator problem. You should have got over 14v when the engine is running if your alternator is working fine, however, you said it was only 13.x. I don't think it is the angle sensor, because you would have had all lights up including ABS, brake light and 4x4 light if your angle sensor goes wrong. Run a test on the alternator.
Is there a non-invasive way to test the alternator? I'd like to rule that out without pulling it off the car...
__________________
2004 E46 M3 Silbergrau - Mein
2004 E53 3.0i TiAG - Wife's
2002 E46 330i TiAG - Sold
1999 E46 328i Schwarz - Sold
1961 VW Beetle GolfBlau Ragtop Sdn - Mein
Reply With Quote
  #29  
Old 05-20-2013, 12:11 PM
Big "J"'s Avatar
Member
 
Join Date: Feb 2008
Location: Kaufman TX (East of DFW)
Posts: 695
Big "J" is on a distinguished road
Check out the other thread on the DSC, ABS and 4x4 with posts from this morning. QSilver put instructions on how to check your alternator volatge from your cluster.
__________________
"I canít understand it. I canít even understand the people who can understand it"

Queen Juliana (1909-2004), of the Netherlands

"If you choose not to decide, you still have made a choice!"


2004 X5 4.8is Imola Red-228K ZF-GA6HP26Z-Sold
2006 X3 3.0i Mystic Blue-175K, ///M pkg 6-Spd Manual- Trading in 6/10/17 for a Mini too!
2003 Silver X5 3.0- sold
2000 VW Beetle 1.8 turbo-165K- Totaled 9/11/16
Reply With Quote
  #30  
Old 05-20-2013, 12:16 PM
Member
 
Join Date: May 2013
Location: Colorado
Posts: 55
Buguyed is on a distinguished road
Quote:
Originally Posted by Big "J" View Post
Check out the other thread on the DSC, ABS and 4x4 with posts from this morning. QSilver put instructions on how to check your alternator volatge from your cluster.
I've been testing via the OBC already.
__________________
2004 E46 M3 Silbergrau - Mein
2004 E53 3.0i TiAG - Wife's
2002 E46 330i TiAG - Sold
1999 E46 328i Schwarz - Sold
1961 VW Beetle GolfBlau Ragtop Sdn - Mein
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 05:32 PM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
© 2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.