Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E70) Forum
Fluid Motor Union
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-08-2013, 10:21 AM
giodog2000's Avatar
Member
 
Join Date: Mar 2013
Location: Montreal
Posts: 462
giodog2000 is on a distinguished road
Problem: iDrive controller won't respond to press

Hi all ,

My controller gradually stopped from responding to the "PRESS" command. Everything else works fine.

I suspect a contact problem maybe????
Should I try to fix this myself and how hard is it to DIY or is this a dealer fix? No more warranty BTW.

Thanks
__________________
His : 2005 X5 4.8is (SOLD)
Hers: 2007 X5 3.0si (SOLD)

_______________
Retired:
1999 518
2000 323i
2002 M3 (beautiful car)
2003 330Ci
Reply With Quote

Sponsored Links

  #2  
Old 11-08-2013, 03:30 PM
brian5's Avatar
Member
 
Join Date: Sep 2007
Location: CT, USA
Posts: 2,925
brian5 is on a distinguished road
It may have just come a little loose. Mine popped right off when I pulling too hard to the side one time. I just pushed it back on hard and it's been fine since then.

Just pull it straight up to remove it.
Reply With Quote
  #3  
Old 11-08-2013, 03:31 PM
Member
 
Join Date: Aug 2012
Location: Boston
Posts: 79
digdesign is on a distinguished road
Happened to me once. Did you try rebooting iDrive? That fixed it for me.
(Push and hold both eject buttons and the volume knob at the same time.)
__________________
-Mick
Reply With Quote
  #4  
Old 11-08-2013, 03:41 PM
giodog2000's Avatar
Member
 
Join Date: Mar 2013
Location: Montreal
Posts: 462
giodog2000 is on a distinguished road
Thanks for the replies guys. I'll keep you posted
__________________
His : 2005 X5 4.8is (SOLD)
Hers: 2007 X5 3.0si (SOLD)

_______________
Retired:
1999 518
2000 323i
2002 M3 (beautiful car)
2003 330Ci
Reply With Quote
  #5  
Old 11-08-2013, 03:41 PM
brian5's Avatar
Member
 
Join Date: Sep 2007
Location: CT, USA
Posts: 2,925
brian5 is on a distinguished road
Quote:
Originally Posted by digdesign View Post
Happened to me once. Did you try rebooting iDrive? That fixed it for me.
(Push and hold both eject buttons and the volume knob at the same time.)
Yes, I think you have a better answer. I thought "What are the eject buttons?" (I was thinking James Bond....).

Then I realized that you meant the DVD and CD eject buttons and the volume knob (or mute button).
Reply With Quote
  #6  
Old 11-08-2013, 08:34 PM
ard ard is offline
Member
 
Join Date: Mar 2006
Location: Sierra Foothills, California
Posts: 5,684
ard is on a distinguished road
part is easy to replace. There have been posts here or over on bimmerfest on this. search
Reply With Quote
  #7  
Old 11-09-2013, 08:04 AM
giodog2000's Avatar
Member
 
Join Date: Mar 2013
Location: Montreal
Posts: 462
giodog2000 is on a distinguished road
Pulled out the knob. Couldn't do much from what I saw so I put the knob back and gave it a pretty heavy strike to pop it back in....IT NOW WORKS!!!!!
__________________
His : 2005 X5 4.8is (SOLD)
Hers: 2007 X5 3.0si (SOLD)

_______________
Retired:
1999 518
2000 323i
2002 M3 (beautiful car)
2003 330Ci
Reply With Quote
  #8  
Old 11-09-2013, 10:28 AM
brian5's Avatar
Member
 
Join Date: Sep 2007
Location: CT, USA
Posts: 2,925
brian5 is on a distinguished road
Quote:
Originally Posted by giodog2000 View Post
Pulled out the knob. Couldn't do much from what I saw so I put the knob back and gave it a pretty heavy strike to pop it back in....IT NOW WORKS!!!!!
Good to hear that that worked
Reply With Quote
  #9  
Old 11-10-2013, 03:17 PM
giodog2000's Avatar
Member
 
Join Date: Mar 2013
Location: Montreal
Posts: 462
giodog2000 is on a distinguished road
Well that didn't last for long...It's now officially dead.
Good thing is I now know how to replace the whole module (controller). A few easy steps to get access to the module and swap.
The real challenge will be to find an affordable controller. I don't want to end up spending the 200$-plus I saw so far on e-bay. I'll call the dealer tomorrow but I doubt it'll be cheaper than that.....
__________________
His : 2005 X5 4.8is (SOLD)
Hers: 2007 X5 3.0si (SOLD)

_______________
Retired:
1999 518
2000 323i
2002 M3 (beautiful car)
2003 330Ci
Reply With Quote
  #10  
Old 11-11-2013, 05:03 PM
soldmystang's Avatar
Member
 
Join Date: Nov 2007
Location: North Carolina
Posts: 675
soldmystang is on a distinguished road
Mine is doing the same thing. My tech pulled the plate and cleaned some contacts. I'll update when I get it back from him.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 08:36 PM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.