Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E70) Forum
Arnott
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-04-2014, 03:08 PM
ART-qitec's Avatar
Member
 
Join Date: Aug 2013
Location: Miami, FL
Posts: 103
ART-qitec is on a distinguished road
ANOTHER issue!?

So my X5's AC decided to stop working and blow hot air on this glorious 90 degree day. I am extremely frustrated and tired of fixing this thing myself so I just dropped it off at the dealer for them to take care of. I'm just curious to see if anyone has had an issue like this before? There were no warning signs or anything. I assume it's the condenser which many people have problems with.

Also in other news, to make up for the constant headaches this car has caused me, I leased a new toy behind my wifes back.
Attached Images
 
Reply With Quote

Sponsored Links

  #2  
Old 08-04-2014, 03:22 PM
motordavid's Avatar
RetiredBum & Semi-RenaissanceMan
 
Join Date: Mar 2005
Location: Mtns of Western NC, & SW FLA
Posts: 16,758
motordavid will become famous soon enoughmotordavid will become famous soon enough
Titz C7!

Dunno on the A/C situ; when mine went out on our '01 E53 several years ago, it was the FSR and a pretty simple fix. In fact, our '01 still has orig Freon charge, all orig A/C parts, et al.

I am Jonesing for a C7 Vert: retired bum budget curtails my 'just go out and get one' impetus, however. Maybe in late 2015, but I still love my dinosaur 2002 C5 Vert.
GL, mD
__________________
Ol'UncleMotor
From the Home Base of Pro Bono Punditry
and 50 Cent Opins...

Our Mtn Scenes, Car Pics, and Road Trip Pics on Flickr:
http://www.flickr.com/photos/4527537...7627297418250/
http://www.flickr.com/photos/4527537...7627332480833/

http://www.flickr.com/photos/[email protected]/

My X Page




Reply With Quote
  #3  
Old 08-04-2014, 04:05 PM
Member
 
Join Date: Jun 2014
Location: USA
Posts: 31
X5-ERROR is on a distinguished road
Maybe when you parked the X5 next to the Vette, the Vette sucked the will to live out of the X5?

By the way, nice choice.
Reply With Quote
  #4  
Old 08-04-2014, 04:44 PM
BGM's Avatar
BGM BGM is offline
Member
 
Join Date: Jul 2007
Location: Chicago, IL
Posts: 1,820
BGM is on a distinguished road
Living in Dallas summer heat and having 2 X5's since '01, haven't had one AC issue (or radiator).
__________________
2008 X5 4.8
Jet Black/Black Nevada/Dark Burl Walnut
Adaptive Drive
Premium Pack
Tech Pack
Climate Pack
Sport Pack
20" Wheel Option
Premium Sound
Sirius Satellite
Rear DVD Entertainment
Multi-Contour Seats
Comfort Access
3rd Row Seat
Heated Front Seats
Running Boards
3M VentureShield Paint Protection Film
Reply With Quote
  #5  
Old 08-04-2014, 08:18 PM
ard ard is offline
Member
 
Join Date: Mar 2006
Location: Sierra Foothills, California
Posts: 5,679
ard is on a distinguished road
Quote:
Originally Posted by X5-ERROR View Post
Maybe when you parked the X5 next to the Vette, the Vette sucked the will to live out of the X5?

By the way, nice choice.
damn funny.
Reply With Quote
  #6  
Old 08-05-2014, 02:08 AM
Member
 
Join Date: Aug 2012
Location: NYC
Posts: 124
euge is on a distinguished road
Hi art,

I had the same problem on my car, an 08 4.8 just like yours. Does the compressor turn on? Try to see if the low pressure line will accept freon, mine didn't and it turned out the belt for the compressor snapped. Replaced it and it was good to go
Reply With Quote
  #7  
Old 08-05-2014, 11:02 AM
ART-qitec's Avatar
Member
 
Join Date: Aug 2013
Location: Miami, FL
Posts: 103
ART-qitec is on a distinguished road
Quote:
Originally Posted by X5-ERROR View Post
Maybe when you parked the X5 next to the Vette, the Vette sucked the will to live out of the X5?

By the way, nice choice.
Reply With Quote
  #8  
Old 08-05-2014, 11:05 AM
ART-qitec's Avatar
Member
 
Join Date: Aug 2013
Location: Miami, FL
Posts: 103
ART-qitec is on a distinguished road
Quote:
Originally Posted by euge View Post
Hi art,

I had the same problem on my car, an 08 4.8 just like yours. Does the compressor turn on? Try to see if the low pressure line will accept freon, mine didn't and it turned out the belt for the compressor snapped. Replaced it and it was good to go
Thanks Euge, but I'm just going to let the dealer fix it this time. I'm tired of fixing this car and as of right now I'm just eagerly waiting for my Tesla to arrive so I can trade the thing in.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 06:07 PM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.