Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > Electronics > Navigation System
Fluid Motor Union
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-29-2006, 12:46 AM
X5 Meister's Avatar
Member
 
Join Date: Mar 2006
Location: Nordschleife
Posts: 5,486
X5 Meister is on a distinguished road
Nav system acting screwy in hot weather

The other day when temperatures hit nearly 100 F, the Nav system in my 2005 X5 started acting majorly funny. First it stopped given directions. Then while in split screen mode the left side of the screen showing the map went completely blank just showing the cursor stuck in the middle of the display. When I got home I went to eject the Nav DVD (latest version) and noticed that the NAV DVD computer was quite hot to the touch (not sure if this is normal). After the car cooled down the Nav system seemed to work just fine.

Over the next couple of days the nav system acted in a simliar manner. Since temperatures have dropped to the 80's the system seems to be working fine.

Has anyone experienced anything like this? I'm even thinking of mounting a large heatsink to the top of the NAV DVD computer to dissipate some of this heat if that is the culprit.
Reply With Quote

Sponsored Links

  #2  
Old 07-29-2006, 01:56 AM
Member
 
Join Date: Mar 2006
Location: Calabasas, California
Posts: 365
inlacal is on a distinguished road
Nav cooling...

You may want to first check to see if the MkIV unit you have has an internal fan. Perhaps it went bad and simply needs replacement?
__________________
2014 X5d
2012 X5d

2008 M5
2004 M3
Reply With Quote
  #3  
Old 07-29-2006, 04:58 AM
trapdoor's Avatar
Member
 
Join Date: Feb 2006
Location: Bristol, UK
Posts: 465
trapdoor is on a distinguished road
Quote:
Originally Posted by mgruber
Has anyone experienced anything like this?
Yes, certainly have. My dealer swapped out my Mk4 Navicomp under warranty as it was thought the fan was u/s.

My symptoms were slightly different - failure to recognise the map, continual rebooting etc. When I ejected the DVD, it was roasting hot.

However, since the replacement was fitted, I haven't had the car left out in the sun for long periods even though we've had temperatures here in the mid to late 30's
Reply With Quote
  #4  
Old 07-29-2006, 12:28 PM
X5 Meister's Avatar
Member
 
Join Date: Mar 2006
Location: Nordschleife
Posts: 5,486
X5 Meister is on a distinguished road
Nav fan

Thanks for the tip on the navagation unit having a fan; I had no idea! I'll poke around it to see if I can see it working, but for certain I will mention this to the dealer at my next visit. Thanks again guys you are awesome!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 11:08 PM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.