Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > Electronics > Navigation System
Arnott
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-27-2014, 12:24 PM
Member
 
Join Date: Oct 2014
Location: UK
Posts: 2
Valiante is on a distinguished road
Mk4 Nav - No power unless I hold Eject

Hi all,

I recently upgraded my Mk3 nav to a Mk4 unit. All worked great for 3 months, then the other day it just went blank on me, and the next day the TV module took over.

Looking at the nav unit, I see the power light is off, but a small light flickers to the left-edge of the DVD slot. If I hold my finger on the Eject button the unit powers up (the red power light comes on) and the nav system displays on the dash-screen, but as soon as I remove my finger it dies and the screen goes blank.

Is this indicative of a common problem? I've taken the unit apart and can see no obvious issues with broken soldering, etc, but I'm by no means an electronics expert.

Any tips / advice welcome.

Many thanks!

Edit: I have exactly the symptoms described in this thread, but there's no ultimate solution there, hence posting.

Last edited by Valiante; 10-27-2014 at 12:36 PM. Reason: I have tried searching to no avail, provided link
Reply With Quote

Sponsored Links

  #2  
Old 02-11-2016, 05:00 PM
Member
 
Join Date: Feb 2016
Location: Portugal
Posts: 3
HO2016PT is on a distinguished road
Hello.

Managed to solve the problem of your MKIV ??
Reply With Quote
  #3  
Old 02-11-2016, 05:04 PM
Member
 
Join Date: Oct 2014
Location: UK
Posts: 2
Valiante is on a distinguished road
Holy thread resurrection, Batman. Yes, I replaced it with another unit and sold the faulty one for spares or repair. I've since sold the car.
Reply With Quote
  #4  
Old 02-11-2016, 05:52 PM
Member
 
Join Date: Feb 2016
Location: Portugal
Posts: 3
HO2016PT is on a distinguished road
Quote:
Originally Posted by Valiante View Post
Holy thread resurrection, Batman. Yes, I replaced it with another unit and sold the faulty one for spares or repair. I've since sold the car.
OK, thanks.
Reply With Quote
Reply

Bookmarks

Tags
broken, eject, mk4, nav, power

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 04:13 AM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.