Xoutpost.com

Xoutpost.com (https://xoutpost.com/forums.php)
-   X5 (E53) Forum (https://xoutpost.com/bmw-sav-forums/x5-e53-forum/)
-   -   What did you do to / for your E53 today?? (https://xoutpost.com/bmw-sav-forums/x5-e53-forum/78921-what-did-you-do-your-e53-today.html)

EODguy 05-12-2022 03:16 PM

Quote:

Originally Posted by Fifty150hs (Post 1220526)
Didn't you recently replace a MAF?

Yeah 2.5 years ago, but with the conditions on the surface of the sun lately I can't say that I'm surprised it died.

Sent from my SM-A730F using Tapatalk

Happy 05-12-2022 11:30 PM

What did you do to / for your E53 today??
 
Quote:

Originally Posted by EODguy (Post 1220524)
Made the mistake of saying that the Witch was doing good and had no problems......

Pull her broom, and her pot! That will teach her!! :rofl: 🤣

Spartan 05-13-2022 03:20 AM

4 Attachment(s)
I've been meaning to post the things I have done, but never got around to it. Probably a good thing as I can put all four in one go here now...


The front windscreen upper external seal, it dries out goes whit and breaks off. I purchased of AliExpress a T piece of rubber with double sided tape on it. plenty wide enough for the car, bought some Silastic windscreen seal, flexible, removed the remaining old seal and cleaned the hole out. Filled it with the flexi seal and then trimmed and fitted the T shaped rubber into it, using Prepsol to to wipe clean any excess sealant. Total cost All in Aussie dollars $13.50
https://xoutpost.com/<a href=&quot;<...ox&quot;/></a>
http://imgbox.com/11pEsS1D



Next was front mudflaps and blackout sequential side indicators, $75.00 I have a spare set of rear mudflaps as I had to buy a full set to get the two front ones.
http://imgbox.com/FYGggYYY
https://xoutpost.com/<a href=&quot;<...ox&quot;/></a>



I fitted DRL's from a kit for MB as they looked good and very bright, wired in so that they come on with engine running and go out with lights on. $40.00
http://imgbox.com/QYZ7YIA9
https://xoutpost.com/<a href=&quot;<...ox&quot;/></a>



Lastly, I fitted the tinted sun sheild on the side windows. $65.00

http://imgbox.com/IJdGTgFo

zener 05-14-2022 01:23 PM

Took it out from garage. Battery was dead for sitting over month. Gonna change fuel pump tomorrow hopefully and need to get it inspected.


EDIT: fuel pump changed. did not help on the lean issue. It's little bit better but still getting lambda control tolerance codes on both banks. Lambda integrators seems ok'ish. Sometime few seconds over 10. Multicaptive is 11-12...

EODguy 05-15-2022 10:40 PM

Still waiting for stealership to get my new MAF in, but in the meantime I'm running with the MAF unplugged and noticed that with it unplugged my air intake sensor is showing engine air at -40c on Torque Pro.....[emoji15]

If anyone has Torque Pro running could you see what readings you get MAF unplugged for intake temp please.

Thanks


PS I am hoping it's not the sensor killing the MAF via temp correction. [emoji28]

Sent from my SM-A730F using Tapatalk

zener 05-15-2022 11:40 PM

Intake air temp sensor is in the maf.

EODguy 05-16-2022 12:49 AM

Quote:

Originally Posted by zener (Post 1220616)
Intake air temp sensor is in the maf.

But why does the no MAF closed loop use a -40c for predetermined data?

Sent from my SM-A730F using Tapatalk

X5chemist 05-16-2022 07:24 AM

Quote:

Originally Posted by EODguy (Post 1220613)
Still waiting for stealership to get my new MAF in, but in the meantime I'm running with the MAF unplugged and noticed that with it unplugged my air intake sensor is showing engine air at -40c on Torque Pro.....[emoji15]Sent from my SM-A730F using Tapatalk

Wow, toast MAF? Dang, I took the OEM one out to clean. I put in a $20 replacement so I could keep driving it. It's still running with a $20 MAF and got 24 MPG on Consumr1 readings for a 336 mile run. :p:

EODguy 05-16-2022 07:30 AM

Quote:

Originally Posted by X5chemist (Post 1220622)
Wow, toast MAF? Dang, I took the OEM one out to clean. I put in a $20 replacement so I could keep driving it. It's still running with a $20 MAF and got 24 MPG on Consumr1 readings for a 336 mile run. :p:

A genuine MAF from BMW is 1,790 SAR, I wish I could sneak into the parts department at night....[emoji2958]

Sent from my SM-A730F using Tapatalk

workingonit 05-16-2022 09:45 AM

Quote:

Originally Posted by X5chemist (Post 1220622)
Wow, toast MAF? Dang, I took the OEM one out to clean. I put in a $20 replacement so I could keep driving it. It's still running with a $20 MAF and got 24 MPG on Consumr1 readings for a 336 mile run. :p:

Can you post a link to the $20 MAF that you bought?

I'm wanting to test with another MAF because my Siemens MAF may be under-reporting and causing the lean codes I've been fighting for 6 months.

Since the $20 MAF works for your X5, perhaps the same manufacturer has a MAF that'll work on my M54.

I'd hate to spend $$$$ for another "OE,OEM, or Genuine BMW" MAF sensor, just to find out that my current (cleaned) sensor is working as well as the replacement; if as you say the $20 unit is good enough to keep using, then it just makes more sense to test with it, and
  • 1) if it is better than the original, it solves my problem,or
  • 2) gives the same readings, then it becomes a reliable spare, or
  • 3) proves worse than my original, then I'm only out $20
.



Sent from my SM-G955U using Tapatalk


All times are GMT -4. The time now is 03:35 AM.

vBulletin, Copyright 2022, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved.