Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X3 (E83) Forum
Arnott
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #11  
Old 03-28-2013, 10:32 PM
AzNMpower32's Avatar
Member
 
Join Date: Mar 2006
Location: WNC
Posts: 6,011
AzNMpower32 is on a distinguished road
Quote:
Originally Posted by 04X3 View Post
Unresolved, dealer quoted me 160 for new pump! I said no thank you.
Just buy the part online and install it yourself. No way is the part $160.
Reply With Quote

Sponsored Links

  #12  
Old 03-28-2013, 11:37 PM
JCL's Avatar
JCL JCL is offline
Premier Member
 
Join Date: Mar 2005
Location: Vancouver, Canada
Posts: 11,853
JCL will become famous soon enoughJCL will become famous soon enough
Quote:
Originally Posted by 04X3 View Post
I believe the problem lies in the plastic impeller of the pump. In cold temps. The impeller may try to propel frozen or half frozen liquid. Increased resistance breaks impeller off, meaning we hear the pump's motor running just fine but because of no impeller we get no pressure.
I've never had a washer pump fail, but then I use ww antifreeze year round. Are you putting water in the reservoir?
__________________
2007 X3 3.0si, 6 MT, Premium, White

Retired:
2008 535i, 6 MT, M Sport, Premium, Space Grey
2003 X5 3.0 Steptronic, Premium, Titanium Silver

2002 325xi 5 MT, Steel Grey
2004 Z4 3.0 Premium, Sport, SMG, Maldives Blue
Reply With Quote
  #13  
Old 03-29-2013, 12:58 PM
Christiano's Avatar
Member
 
Join Date: Apr 2011
Location: Brazil
Posts: 226
Christiano is on a distinguished road
Quote:
Originally Posted by JCL View Post
I've never had a washer pump fail, but then I use ww antifreeze year round. Are you putting water in the reservoir?
Yes, could be a frozen impeller, but I live in Brazil...

BTW, I grab one in ebay by 24buxs. Look for BMW E46 E90 X5 E60 E65 E66 Z4 X3 HEADLIGHT WASHER PUMP***OE/OEM QUALITY & FIT 1000+ SOLD" SHIPS 12/24 Hours**

Chris

Last edited by Christiano; 03-29-2013 at 01:04 PM.
Reply With Quote
  #14  
Old 03-29-2013, 01:34 PM
TerminatorX5's Avatar
Member
 
Join Date: Jul 2006
Location: Stafford, VA & Harrisburg, PA - USA
Posts: 5,735
TerminatorX5 is on a distinguished road
exactly what happened to mine - the pump is spinning but impeller was broken. replaced the pump, about $45 for part, 5 minutes job, pull the old pump out, switch hoses, pull the new one in...

in cold weather use the fluid that is good to minus whatever, to prevent from freezing...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 11:46 PM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.