Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E53) Forum
Arnott
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #11  
Old 10-12-2020, 12:43 AM
TiminIndy's Avatar
Member
 
Join Date: Aug 2015
Location: Indianapolis, IN USA
Posts: 211
TiminIndy is on a distinguished road
Oh, that fuse is fine - had it out today when I did the amp swap.


Any other ideas?
__________________
Tim in Indy
2006 X5 3.0i
Sport & Cold Weather Package
Reply With Quote

Sponsored Links

  #12  
Old 10-13-2020, 08:36 PM
Member
 
Join Date: Feb 2018
Location: Half Moon Bay
Posts: 38
syncrocrick is on a distinguished road
I have a very similar problem on my 2003 X5. Makes me crazy. Sometimes it works for days without issues, and sometimes it shuts on/off every 5 minutes. Everything else in the unit works, but I am not able to turn the radio on (the yellow light next to the button is off too I believe).

I tried pulling the fuse 73 on and off, and that seemed to help but the fuse itself was fine.

At this junction I have no idea what could be the problem.
Reply With Quote
  #13  
Old 10-13-2020, 09:19 PM
Member
 
Join Date: Oct 2013
Location: on earth
Posts: 1,081
puddinboo is on a distinguished road
Have you checked the connectors from behind the radio to see if they are burnt at all? Could be a possible loose connection causing an arc and heating up.
Quote:
Originally Posted by TiminIndy View Post
Please tell me more. I went for a ride, and sure enough, after about 10 minutes, it stopped working again. It is definitely heat related. I have found that on cold mornings, it stays on for my entire 35 minute commute to work, but when it is hot outside, it only lasts 5-10 minutes.
Sent from my SM-G950W using Xoutpost.com mobile app
__________________
2003 bmw x5 3.0i ,219000km build date 2003-08-18
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 03:22 PM.
vBulletin, Copyright 2020, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.