Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E53) Forum
Fluid Motor Union
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #11  
Old 07-06-2023, 10:22 PM
Happy's Avatar
Member
 
Join Date: Jan 2013
Location: Golden Coast/Lake Houston
Posts: 1,455
Happy is on a distinguished road
Replacement sound system / Nav Screen in 2023

Quote:
Originally Posted by PropellerHead View Post
The secret is in programming the amp. Set each speaker's distance to the driver's ear. Set electronic crossovers to the limits on what each speaker can actually produce (and still sound good). Then, fill the bottom frequecies with a sub. If you do it well and aren't beholden to ridiculous competition level sound EQ goals, You will be very happy.
+100..!

That is exactly how it is done! Great advice Prop.!


E53 RiPPeR
XOuTPoST jUNkiE
ReVELaTiON 22:21
__________________
02 BMW 5 Speed Supercharged Ethanol Burnin Meth Injected E53

Reply With Quote

Sponsored Links

  #12  
Old 07-07-2023, 01:02 PM
Member
 
Join Date: Jan 2020
Location: Houston TX
Posts: 309
Nolimite39 is on a distinguished road
I'll throw my experience in. When I bought mine I assumed the entire system had been replaced because the DSP amp and controller were gutted, Memphis crossovers were installed, along with a early Windows Mobile HU and a 5 channel JL amp. I could never get the sound to work so I ripped the HU out and replaced it with an AVIN A4. Everything worked well and sounded amazing. Not quite as good as the Logic 7 in the e90, but close. Low an behold when I pulled a door card to do the handle carrier sometime later, I found out that the speakers were all STOCK. They are capable of producing very good sound with the proper amp/crossover/filter pushing them.
__________________
Again Daily Driven SC'd 4.6iS, whats the point of having a sweet ride if you dont use it all the time.
Reply With Quote
  #13  
Old 09-04-2023, 10:25 AM
Member
 
Join Date: May 2022
Location: London
Posts: 32
hamza is on a distinguished road
Sorry I never updated this... was a bit rushed getting it all fixed and the straight off on a euro road trip with the X.

In the end I changed all the speakers, replaced them with Hertz drivers. I pulled out the OEM speakers, cut them out of their plastic frames and then bonded the new drivers into the OEM plastic frames. Made for a nice neat install and no cutting into the wiring loom as all the original OEM connectors were retained.

I also threw in a 10" sub (with its own amp) into the little cubby hole that the original OEM DSP sub would fit into.

I decided to keep the OEM head unit, BM54 and E53 amps in the end. I had to replace the E53 with a new (second hand) unit which was a total pain getting one that actually still worked.

The BM54 had a blown channel so it went off to Cartronics for repair and upgrade... which in itself was more a drama that i had hoped for. First time it came back I had a lot of alternator whine in the speakers. So it went back again (no cost) and they repaired it again with some different components and then it was fine.

There's a GROM unit for bluetooth audio that replaced the CD player.

Overall I'm ok with it. Its not amazing, but it sounds ok. The weak link is probably the OEM amps and/or the bluetooth streaming unit. Not really looked into it to narrow it down.

Was a LOT of work, especially replacing all the speakers into the OEM plastic frames. I'd share some pictures (I took some) but not sure there's a way to upload to this forum.
Reply With Quote
  #14  
Old 09-23-2023, 07:42 PM
Member
 
Join Date: Apr 2012
Location: SoCal
Posts: 1,684
g300d is on a distinguished road
Hamza, what model/brand sub did you fit in the boot? It's a tight fit there and I'm always looking out for options in case I decide to upgrade.

Yeah I am getting to the end of my rope with the system in the 3.0 with dsp.

Head unit display pixels as usual. Bought an LCD, used a part number from the big thread on it here, and it was the wrong angle lol. Then the display backlight died...

Then I got speaker whine anytime the car was running. Then came severe battery drain with the car off.

Pulled all the fuses for now while I plan a course of action.
__________________
04 X5 3.0i auto
03 X5 4.6is
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 08:42 PM.
vBulletin, Copyright 2023, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.