Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E70) Forum
Arnott
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-20-2017, 03:44 AM
Member
 
Join Date: May 2014
Location: Derby UK
Posts: 63
Google44 is on a distinguished road
New (to me) 2008 X5 3.0 d M sport with issues

Hi everyone


Recently I got 2008 X5 with a few issues to sort. I was wondering if someone can help.

1. Common fault - parking brake lite is yellow. Apparently, box has been replaced under the rear suspesion. However, done ISTA on it and claim it can talk to ECU, switch responses with 5V difference when pressed. Sounds like motor is not doing anything in. Also ISTA slaims the emergency release is activated...Any ideas where to start?

2. Passanger side heated set does not work. The light does not lit up at all. Driver side is OK. Again, there is 3 fuse boxes in this car so not sure where to start. Diagram claims it is fues 100,112,139,140,141. Is it realy all of them?

3. I think the bag of it sags a bit down if left over a period of time. Since both side drop equally there must be a leak in compresor. Reading around this forum people claim to remove salenoid, clean it and it was fine after. Not sure where salenoid is on it to be honest. Guess compressor itself is in boot somewhere. Being 7 seater how easy is to get to it.

4. claims to have reconditioned injectors but burns 33 mpg on motorway....
sounds a bit to much.

5. Rear air climate control module is dead - no power. Again, first point of check would be the fuse which is a struggle to locate at the moment

Thanks

Last edited by Google44; 06-20-2017 at 05:51 AM.
Reply With Quote

Sponsored Links

  #2  
Old 06-20-2017, 08:40 AM
swooshdave's Avatar
Member
 
Join Date: Feb 2017
Location: Portland, Oregon
Posts: 36
swooshdave is on a distinguished road
https://xoutpost.com/bmw-sav-forums/...anual-bmw.html
Reply With Quote
  #3  
Old 06-20-2017, 09:08 AM
Member
 
Join Date: May 2014
Location: Derby UK
Posts: 63
Google44 is on a distinguished road
Thanks. Did have a look at that. Does not answer all my questions but it is a nice start.

Thanks again
Reply With Quote
  #4  
Old 06-20-2017, 09:10 AM
swooshdave's Avatar
Member
 
Join Date: Feb 2017
Location: Portland, Oregon
Posts: 36
swooshdave is on a distinguished road
Have you searched YouTube videos? Amazing amount of stuff there.
Reply With Quote
  #5  
Old 06-20-2017, 10:11 AM
Member
 
Join Date: Aug 2016
Location: Detroit, MI
Posts: 265
Nanniepoo is on a distinguished road
If the emergency release has been activated, reset it. Look up on youtube E70 parking brake release.

Do some inspection on the sagging bags. Both our bags sagged occasionally and replacing the bags fixed it. Compressor itself isn't bad if it raises back up, so check valve body and the bags. I hate recommending just throwing parts at it, but the bags routinely go bad at the 8-10 year mark, so if they haven't been done even if they aren't the problem they're probably close to giving up. Compressor and valve body are under the car, under the American passenger (right) side, just have to remove some trim pieces. All the info is out there, it's a common DIY.

What do you mean by 4? Burns 33mpg?

I still haven't found a good fuse box diagram, so unfortunately can't help you there.

Last edited by Nanniepoo; 06-20-2017 at 10:12 AM. Reason: UK backwardness
Reply With Quote
  #6  
Old 06-20-2017, 02:59 PM
Member
 
Join Date: May 2014
Location: Derby UK
Posts: 63
Google44 is on a distinguished road
Quote:
Originally Posted by Nanniepoo View Post
If the emergency release has been activated, reset it. Look up on youtube E70 parking brake release.

Do some inspection on the sagging bags. Both our bags sagged occasionally and replacing the bags fixed it. Compressor itself isn't bad if it raises back up, so check valve body and the bags. I hate recommending just throwing parts at it, but the bags routinely go bad at the 8-10 year mark, so if they haven't been done even if they aren't the problem they're probably close to giving up. Compressor and valve body are under the car, under the American passenger (right) side, just have to remove some trim pieces. All the info is out there, it's a common DIY.

What do you mean by 4? Burns 33mpg?

I still haven't found a good fuse box diagram, so unfortunately can't help you there.

4. it does 33 miles per gallon. I've got e53 which does 40+ on steady drive.
Think will do a good service first including engine breather and thermostat to start with.



How about rear climate control. It is dead. where would the fuse for it be please?
Reply With Quote
  #7  
Old 06-20-2017, 06:49 PM
Member
 
Join Date: May 2014
Location: Derby UK
Posts: 63
Google44 is on a distinguished road
This is the error list from ISTA:

Sent from my ONE A2003 using Tapatalk
Reply With Quote
  #8  
Old 06-20-2017, 06:50 PM
Member
 
Join Date: May 2014
Location: Derby UK
Posts: 63
Google44 is on a distinguished road
I've also check the parking brake switch is OK.
Reply With Quote
  #9  
Old 06-21-2017, 08:00 AM
Member
 
Join Date: May 2014
Location: Derby UK
Posts: 63
Google44 is on a distinguished road
Had a look at the fuses. Cannot find out what fuse should be for rear climate control.

Can I assume that if front works then rear should be on as well? My Idrive menu does not have 'rear off/on' option. I could be because it has no power?
Reply With Quote
  #10  
Old 06-21-2017, 01:49 PM
ard ard is offline
Member
 
Join Date: Mar 2006
Location: Sierra Foothills, California
Posts: 5,586
ard is on a distinguished road
Quote:
Originally Posted by Google44 View Post
Had a look at the fuses. Cannot find out what fuse should be for rear climate control.

Can I assume that if front works then rear should be on as well? My Idrive menu does not have 'rear off/on' option. I could be because it has no power?
No, you cannot assume that.

Why not take your user name and employ that concept to search for E70 fuse diagrams?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 03:13 AM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.