Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E70) Forum
Arnott
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-07-2019, 01:27 AM
Member
 
Join Date: Jan 2016
Location: USA TEXAS
Posts: 3
nikolay is on a distinguished road
e70 2007 trailer hitch coding

Hi. I'm using the OEM hitch kit and OEM wiring. I Added +AHMU to the FA for both CAS and FRM with NCS expert ,but when i try to the codding i am getting error : COAPI 2020 ECU does not answer IFH-0009. No response from controlunit AHM_E65

Attached Images
 
Reply With Quote

Sponsored Links

  #2  
Old 04-07-2019, 10:57 AM
Member
 
Join Date: May 2010
Location: on the edge of existence
Posts: 1,360
blue dragon will become famous soon enough
HKL
SCH_FBD
aktiv
SCH_TOEHKI
aktiv
TASTER_FBD
aktiv

FRM-
LWR_STROM_HALT
wert_01
LWR_STROM_NORMAL
wert_01
LWR_STROM_RAMPE
wert_01

KOMBI
AHM_APPL_MONITOR
aktiv

RPDC
ANHAENGERKUPPLUNG
aktiv
AHK_OFFSET
offset_1
AHK_AUSBLENDUNG
aktiv

CIC
MACRO_TRAILER_COUPLING
aktiv



AHM
AENDERVARIANTE_AHM
us
CCMELDUNG_ABRISS_AHV
cc_04bh
CCMELDUNG_FEHLER_AHM
cc_04bh
CCMELDUNG_VERRIEGEL_AHV
cc_04bh
START_CCM
klemme_15
TYP_AHV_SG
keine_ahv
SL_BEI_KZL_AKTIV
nicht_aktiv


Did you connect the AHM module that comes with the the OE wiring harness?
__________________


| '17 F15 X5 35D - Work horse | '17 F48 X1 MSport - Wife's daily | '17 F30 340i MSport - My daily | '09 E70 X5 35D - Out to pasture |
Reply With Quote
  #3  
Old 04-09-2019, 08:21 AM
Member
 
Join Date: Jan 2017
Location: Chicago
Posts: 539
Purplecty is on a distinguished road
Are these the differences in each of the listed modules after retrofitting the trailer?

Sent from my SM-N960U using Xoutpost.com mobile app
__________________
02 Imola on Black Dinan S2 4.6iS
00 RoyalRot on Sand/Black 740i Short Sport
Reply With Quote
  #4  
Old 04-09-2019, 01:41 PM
Member
 
Join Date: Mar 2017
Location: Iowa
Posts: 54
Badsmerf is on a distinguished road
Do you see AHM in FA and CAS? Looks like BD gave you a nice list of all the modules that need to be coded. My AHM didn't come with all the lines, so I had to add them and the command myself to make it work.
Reply With Quote
  #5  
Old 04-10-2019, 01:24 AM
Member
 
Join Date: Jan 2016
Location: USA TEXAS
Posts: 3
nikolay is on a distinguished road
I forgot to plug the 3-pin BUS connector from the trailer wiring harness .Now i can connect with AHM module . I went true all the trouble to install ISTA P to find out this. But when i try to do the codding with ISTA P it is making me to do all kinds of updates and I was waiting 1+ hours and i just stop it because my battery was dying. I am going to use the NCS expert and do it manually .



I dont have HKL module(because i dont have lift gate option) and in my FRM module I cant find :LWR_STROM_HALT
wert_01
LWR_STROM_NORMAL
wert_01
LWR_STROM_RAMPE
wert_01

To make my lights work do I just need my AHM module programed ?
My CCC is red because i did CIC conversion
Attached Images
 
Reply With Quote
  #6  
Old 04-10-2019, 06:32 AM
Member
 
Join Date: May 2010
Location: on the edge of existence
Posts: 1,360
blue dragon will become famous soon enough
Skip the HKL step, I included it in error
__________________


| '17 F15 X5 35D - Work horse | '17 F48 X1 MSport - Wife's daily | '17 F30 340i MSport - My daily | '09 E70 X5 35D - Out to pasture |
Reply With Quote
  #7  
Old 04-05-2020, 10:22 PM
Member
 
Join Date: Sep 2019
Location: Dallas-Fort Worth
Posts: 2
E70X5M35i is on a distinguished road
Question

Quote:
Originally Posted by nikolay View Post
Hi. I'm using the OEM hitch kit and OEM wiring. I Added +AHMU to the FA for both CAS and FRM with NCS expert ,but when i try to the codding i am getting error : COAPI 2020 ECU does not answer IFH-0009. No response from controlunit AHM_E65

I am also getting the same error when trying to read the AHM ecu module. I believe I successfully added it to CAS & FRM and it shows up as an ECU module after adding it but when I go to read it, I get those same error messages.

Do I have to purchase the OEM wiring harness and install this if I want to read the AHM module? I haven't done that yet.. is that why I'm getting the message?

Last edited by E70X5M35i; 04-05-2020 at 10:48 PM.
Reply With Quote
  #8  
Old 04-07-2020, 08:25 AM
Member
 
Join Date: May 2010
Location: on the edge of existence
Posts: 1,360
blue dragon will become famous soon enough
The OE harness comes with the module. You can't code it if it isn't physically connected to your car
__________________


| '17 F15 X5 35D - Work horse | '17 F48 X1 MSport - Wife's daily | '17 F30 340i MSport - My daily | '09 E70 X5 35D - Out to pasture |
Reply With Quote
  #9  
Old 04-07-2020, 08:30 AM
Member
 
Join Date: Sep 2019
Location: Dallas-Fort Worth
Posts: 2
E70X5M35i is on a distinguished road
Understood. Appreciate the response blue dragon! Thanks for your work and others in figuring out which settings need to be coded in order to add a hitch. I saw this thread and others in trying to figure out exactly which settings need to be coded.

I ordered the harness yesterday. Hopefully in 1-2 weeks time, Iíll have the harness and hitch installed . Love your X5 btw ó looks awesome!
Reply With Quote
  #10  
Old 06-16-2020, 09:33 PM
Member
 
Join Date: Jun 2020
Location: Oregon
Posts: 2
Laecaon is on a distinguished road
I think I am missing something. 08 E70. All wired up. I did manage to add +AHMU to the CAS and FRM with NCS Expert, and the AHM module shows up now. But its missing code(only has 2 options). And FRM is missing the LRM_STROM_*** codes.

Blue Dragon, it appears you posted CIC codes, do you have CCC? I dont have a RPDC module, but I do have PDC (which I am assuming controls front and rear).



And while I have managed to use NCS Expert to alter code on both this E70, and a E46 before, I have never added code. It is as simple as pasting in code in the right format?


Thanks guys for any help. I guess this is me not understanding NCS Expert enough.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 07:03 AM.
vBulletin, Copyright 2020, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
© 2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.