Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > Electronics > Bluetooth
Fluid Motor Union
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #11  
Old 11-19-2013, 10:05 PM
Member
 
Join Date: Nov 2013
Location: Chicago Illinois
Posts: 720
Brandon002 is on a distinguished road
Quote:
Originally Posted by 04X3 View Post
Alright, here is part number:

84.116952218-01

USA 5/5/2004

SW: 35 HW:30
My TCU has the same part number and I can't get my phone to pair either. Nobody can confirm if the car does or doesn't have BT. I also have the card in my owner's manual, can visually see the BT antenna in the rear of the car and it is plugged in to the TCU.

My phone just won't find the car and vice versa.
Reply With Quote

Sponsored Links

  #12  
Old 08-14-2015, 11:23 PM
Member
 
Join Date: Jul 2015
Location: Ohio
Posts: 91
iansanderson is on a distinguished road
I have an 04/04 build X5 with Assist. I noticed the Bluetooth antenna in the back. My TCU has a Bluetooth logo and PK. However, Bluetooth is disabled at the factory on pre 09/04 cars for some reason mine included. All the TEL button would say when pressed was "PHONE CONNECTED?" Using NCS expert, I coded the TCU to BT operation and BT_HANDSET to aktiv, and it immediately started working. Only annoying part is that is reverts to speaker when the other party picks up the phone. Might be an iPhone only problem but it only happens in the X5.
Reply With Quote
  #13  
Old 09-01-2015, 02:22 AM
Onizukachan's Avatar
Member
 
Join Date: Aug 2015
Location: El Paso TX
Posts: 27
Onizukachan is on a distinguished road
This was extremely timely, as I had just started looking for a TCU for the GF's July 04 build date, due to the consensus being that a TCU SWAP was the only way to get it to work. If however we can merely invest the same $300 into an older laptop and NCS expert, I'd much rather go that way!

Could you clarify what you mean by it "reverts to speaker"? Does the call drop back to handset when the other person answers?
Reply With Quote
  #14  
Old 09-01-2015, 11:10 AM
Member
 
Join Date: Jul 2015
Location: Ohio
Posts: 91
iansanderson is on a distinguished road
It's really annoying. I'm sure a later build <KW:> TCU would eliminate it possibly from an X3.

What is does on my iPhone is when you place a call, it reverts to handsfree. Then I will click the audio button on the iPhone and switch it back to handset. Then when the other party answers, it automatically reverts back to handsfree again, and you have to click the button on the phone again, and move it back to handset. After that it sticks.

I sifted through all of the coding options, and messed with a few, but nothing changed it. So, it is most likely a programming issue in the older modules, and since the TCU is not programmable, you have to replace it.
Reply With Quote
  #15  
Old 09-01-2015, 11:14 AM
jgold47's Avatar
Member
 
Join Date: Oct 2012
Location: Michigan
Posts: 665
jgold47 is on a distinguished road
if your connected to blue tooth and dial the phone either from the phone or the car it defaults to bluetooh.

if you answer from your handset, it defaults to handset. If you answer from the car, it defaults to car.

I think what you're describing is normal.
__________________
For Sale Thread:
http://www.xoutpost.com/classifieds/...ia-bridge.html

2004 X5 3.0i - Sold
1998 328i Convertible (e36) -sold
2004 325xi (e46)- sold

Any questions?: DICE mediabridge|gauge rings|LED Angel Eyes|front door carrier|GT1/DIS/INPA/NCS|bluetooth retrofit|SIRIUS Retrofit|fuel filter|Dorman DISA|Roof Rack Delete|Sunroof drains|AC drains|rear sway bar swap|o2 sensors|VCG|Osram Night Breakers
Reply With Quote
  #16  
Old 09-01-2015, 11:25 AM
Member
 
Join Date: Jul 2015
Location: Ohio
Posts: 91
iansanderson is on a distinguished road
Quote:
Originally Posted by jgold47 View Post
if your connected to blue tooth and dial the phone either from the phone or the car it defaults to bluetooh.

if you answer from your handset, it defaults to handset. If you answer from the car, it defaults to car.

I think what you're describing is normal.
The part that is not normal is when it reverts back to handsfree when the calling party connects on the call.

Example:

Call 555-1234. Ringback is heard. <SPEAKER> Take phone, press Audio, press iPhone. <HANDSET> The other person picks up the phone and says "Hello", call is now automatically flipped back to <SPEAKER> requiring you to again, flip the call back to handset if you want privacy.

No BMW I have ever owned has done that. If you select handset, it stays on handset for the entire call.
Reply With Quote
  #17  
Old 09-01-2015, 11:27 AM
jgold47's Avatar
Member
 
Join Date: Oct 2012
Location: Michigan
Posts: 665
jgold47 is on a distinguished road
Quote:
Originally Posted by iansanderson View Post
The part that is not normal is when it reverts back to handsfree when the calling party connects on the call.

Example:

Call 555-1234. Ringback is heard. <SPEAKER> Take phone, press Audio, press iPhone. <HANDSET> The other person picks up the phone and says "Hello", call is now automatically flipped back to <SPEAKER> requiring you to again, flip the call back to handset if you want privacy.

No BMW I have ever owned has done that. If you select handset, it stays on handset for the entire call.
got it. that is strange. I'll try it later
__________________
For Sale Thread:
http://www.xoutpost.com/classifieds/...ia-bridge.html

2004 X5 3.0i - Sold
1998 328i Convertible (e36) -sold
2004 325xi (e46)- sold

Any questions?: DICE mediabridge|gauge rings|LED Angel Eyes|front door carrier|GT1/DIS/INPA/NCS|bluetooth retrofit|SIRIUS Retrofit|fuel filter|Dorman DISA|Roof Rack Delete|Sunroof drains|AC drains|rear sway bar swap|o2 sensors|VCG|Osram Night Breakers
Reply With Quote
  #18  
Old 09-01-2015, 07:27 PM
Onizukachan's Avatar
Member
 
Join Date: Aug 2015
Location: El Paso TX
Posts: 27
Onizukachan is on a distinguished road
Sorry to annoy, but I tried pulling my tcu today and lost my last 8mm somewhere in the guts of the trunk before I could finish the last bolt.

Could you tell me how many antenna connections your Tcu has, and if you have a second pair joined and wrapped like mine does?

If all that is not working is staying on handset automatically, and having to manually switch back to private/ handset mode, we can absolutely live with that.


Ours has 3 black right angle connections to the tcu, and wrapped separately is a black connected to a purple plus a 3 pin lead.



As soon as I can find another 1/4 drive 8mm to use on my flexi-drive so I don't lose it this time, I'll finish pulling the tcu and get some picks of the other side.


EDIT:
Was able to get it out and confirm it matches the tag on the glovebox card.

Looks like I have a 4th TCU connector that isn't being used, and if the sticker indicates the color, is it supposed to have a purple connectored wire that I haven't found yet? A little confused here honestly.

Attaching some pics, sorry for the quality, don't get to work on it in the day time much.







Thanks in advance,
Rick.

Last edited by Onizukachan; 09-01-2015 at 11:54 PM.
Reply With Quote
  #19  
Old 09-02-2015, 11:46 PM
Onizukachan's Avatar
Member
 
Join Date: Aug 2015
Location: El Paso TX
Posts: 27
Onizukachan is on a distinguished road
From reading more on the e83, it seems like the white cable is the BT antenna, not purple like on some other cars, so we should be good to go.

Gf just went halvsies on a computer from eBay with TIS, GT1, NCS expert, Progman etc on it, cable etc all ready to go, so sometime next week I will be trying to give this a go.
I hate Windows machines and didn't want to deal with the headaches of trying to learn unfamiliar software, plus set up of half a dozen programs and the computer itself, so this option worked out great for us even if it was more expensive than buying an old laptops and setting it all up from scratch.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 06:46 AM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.