Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E53) Forum
Fluid Motor Union
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #14551  
Old 01-08-2022, 03:06 PM
Member
 
Join Date: Jul 2021
Location: Finland
Posts: 182
zener is on a distinguished road
Quote:
Originally Posted by zener View Post
No, codes will come up almost instant while driving. CEL will take some time to light up. Reset will help for few kilometers but not long.

Edit: new smoke test done. No more leaks. Hopefully maf will arrive next week.
It was -27c and tried to start it. Would not idle until i kept it alive with throttle for few minutes. After that ran fine for few minutes and then it when't all mad and ran with 4-5 cylinders. Scanned codes with inpa and 4-5-6 misfire and lambda control tolerance limits on both banks. Got running with all cylindes after clearing codes. Drove the car for about 30-40km and eml abs/dsc lights where on. This time code was llfs at mechanical/llfs jammed closed. Icv is new, so I doubt it's jammed.
__________________
Current rides: E65 730d, E53 X5 3.0i, F10 520d


BMW glasses on since 2004.
Reply With Quote

Sponsored Links

  #14552  
Old 01-08-2022, 04:11 PM
Member
 
Join Date: Jul 2016
Location: Menlo Park, CA
Posts: 2,080
Fifty150hs is on a distinguished road
Quote:
Originally Posted by zener View Post
It was -27c and tried to start it. Would not idle until i kept it alive with throttle for few minutes. After that ran fine for few minutes and then it when't all mad and ran with 4-5 cylinders. Scanned codes with inpa and 4-5-6 misfire and lambda control tolerance limits on both banks. Got running with all cylindes after clearing codes. Drove the car for about 30-40km and eml abs/dsc lights where on. This time code was llfs at mechanical/llfs jammed closed. Icv is new, so I doubt it's jammed.
I've been getting intermittant ICV jammed codes along with the car going into engine safe mode and throwing trifecta. Sometimes, like last time, I just shut it off and restarted and it has been fine. Before that I had to clear codes twice. The second time I also pulled the ICV and cleaned it even though it was rattling around as it should. Had codes after that , but the restart cleared them. Hard to chase a problem like that.
Reply With Quote
  #14553  
Old 01-08-2022, 08:13 PM
andrewwynn's Avatar
Member
 
Join Date: Jun 2015
Location: Racine, WI
Posts: 9,752
andrewwynn will become famous soon enough
I got ICV stuck code turned out to be a missing hose clamp on the intake boot.
__________________
2011 E70 N55 (me)
2012 E70 N63 (wife)
Reply With Quote
  #14554  
Old 01-08-2022, 09:49 PM
Member
 
Join Date: Jul 2016
Location: Menlo Park, CA
Posts: 2,080
Fifty150hs is on a distinguished road
Quote:
Originally Posted by andrewwynn View Post
I got ICV stuck code turned out to be a missing hose clamp on the intake boot.
That kind of makes sense. Mine aren't missing.
Reply With Quote
  #14555  
Old 01-08-2022, 09:58 PM
andrewwynn's Avatar
Member
 
Join Date: Jun 2015
Location: Racine, WI
Posts: 9,752
andrewwynn will become famous soon enough
But a leak in disa or similar could cause similar error. Or defective ICV of course. "rattles" doesn't mean it works just means it "could" work.


Sent from my iPhone using Tapatalk Pro
__________________
2011 E70 N55 (me)
2012 E70 N63 (wife)
Reply With Quote
  #14556  
Old 01-08-2022, 11:00 PM
Member
 
Join Date: Jul 2016
Location: Menlo Park, CA
Posts: 2,080
Fifty150hs is on a distinguished road
Quote:
Originally Posted by andrewwynn View Post
But a leak in disa or similar could cause similar error. Or defective ICV of course. "rattles" doesn't mean it works just means it "could" work.


Sent from my iPhone using Tapatalk Pro
Agreed, but I replaced my last one at 206,000 miles, about 60,000 miles ago. I'd have to do some research, but my recollection is that the only thing available was genuine BMW. I'd think it would last longer than 60,000 miles. Hopefully I bought it at FCP.
Reply With Quote
  #14557  
Old 01-15-2022, 05:41 PM
Member
 
Join Date: Jul 2021
Location: Finland
Posts: 182
zener is on a distinguished road
Received so called tested and working maf from ebay that I ordered and it's broken. Just gives air flow meter code right away. Damn it, I was so keen on testing if the hella maf is the culprit... Well, gotta find another one and ask money back from the one that I got.
__________________
Current rides: E65 730d, E53 X5 3.0i, F10 520d


BMW glasses on since 2004.
Reply With Quote
  #14558  
Old 01-15-2022, 05:43 PM
andrewwynn's Avatar
Member
 
Join Date: Jun 2015
Location: Racine, WI
Posts: 9,752
andrewwynn will become famous soon enough
I might still have my original.


Sent from my iPhone using Tapatalk Pro
__________________
2011 E70 N55 (me)
2012 E70 N63 (wife)
Reply With Quote
  #14559  
Old 01-15-2022, 06:02 PM
Member
 
Join Date: Jul 2016
Location: Menlo Park, CA
Posts: 2,080
Fifty150hs is on a distinguished road
Quote:
Originally Posted by zener View Post
Received so called tested and working maf from ebay that I ordered and it's broken. Just gives air flow meter code right away. Damn it, I was so keen on testing if the hella maf is the culprit... Well, gotta find another one and ask money back from the one that I got.
Get a Siemans
Reply With Quote
  #14560  
Old 01-15-2022, 06:15 PM
Member
 
Join Date: Jun 2021
Location: Austin, TX
Posts: 684
X5chemist is on a distinguished road
Quote:
Originally Posted by zener View Post
Received so called tested and working maf from ebay that I ordered and it's broken. Just gives air flow meter code right away. Damn it, I was so keen on testing if the hella maf is the culprit... Well, gotta find another one and ask money back from the one that I got.
Try this one: https://www.ebay.com/itm/MAF-Mass-Ai...-127632-2357-0

I ordered one to clean the OEM one. It been running great for a year now. I have the OEM one as a back up.
__________________
'06 X5 3.0i - bought @143,123 miles (12/26/20)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 08:24 AM.
vBulletin, Copyright 2022, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.