Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > Electronics > Mobile Electronics Forum
Arnott
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-14-2006, 05:39 PM
broknlgs24's Avatar
Premier Member
 
Join Date: Mar 2005
Location: Maryland
Posts: 2,027
broknlgs24 is on a distinguished road
Unhappy Sirius Issues

I finally got around to installing my
Sirius System; however, I am having
issues. Upon connecting everything,
I do not get the SAT. option on my NAV
Screen. If I switch to the CD Changer, I
can hear the changer switching CD's, but
I get no sound. What am I missing?
I have an '03 X5 w/ DSP. I also replaced
the radio module w/ what I thought was
the newer one that I needed. Please help....
__________________
Reply With Quote

Sponsored Links

  #2  
Old 01-14-2006, 06:13 PM
TQ2K's Avatar
Member
 
Join Date: Mar 2005
Location: West Chester, PA
Posts: 2,530
TQ2K is on a distinguished road
Quote:
Originally Posted by broknlgs24
I finally got around to installing my
Sirius System; however, I am having
issues. Upon connecting everything,
I do not get the SAT. option on my NAV
Screen. If I switch to the CD Changer, I
can hear the changer switching CD's, but
I get no sound. What am I missing?
I have an '03 X5 w/ DSP. I also replaced
the radio module w/ what I thought was
the newer one that I needed. Please help....
Hit the same issue when I installed my Sirius radio. The reason for mine not working is that the CD changer wasn't compatible with the Sirius radio so I had to get a newer model of the changer.

This could be the same problem for you. Check with your dealer and have them verify that the model number of your changer is compatible with your Sirius radio.
__________________
TQ2K


'04 N62 - Alpine White/Truffle
'03 S62 - Petrol Mica/Champagne
'97 S52/4/5 - Alpine White/Dove
'91 M42/4/5 - Brilliantrot/Tan
Reply With Quote
  #3  
Old 01-14-2006, 06:16 PM
broknlgs24's Avatar
Premier Member
 
Join Date: Mar 2005
Location: Maryland
Posts: 2,027
broknlgs24 is on a distinguished road
would that also keep me from seeing
the SAT option when i Press MODE?
__________________
Reply With Quote
  #4  
Old 01-14-2006, 06:21 PM
TQ2K's Avatar
Member
 
Join Date: Mar 2005
Location: West Chester, PA
Posts: 2,530
TQ2K is on a distinguished road
Did you properly connect the two cd changer cables to the Sirius module and have a pair of extension cables back to the cd changer?

My suggestion is to isolate it first, just connect the changer and see if it works. Then just connect the Sirius module and see what happens.
__________________
TQ2K


'04 N62 - Alpine White/Truffle
'03 S62 - Petrol Mica/Champagne
'97 S52/4/5 - Alpine White/Dove
'91 M42/4/5 - Brilliantrot/Tan
Reply With Quote
  #5  
Old 01-14-2006, 06:37 PM
broknlgs24's Avatar
Premier Member
 
Join Date: Mar 2005
Location: Maryland
Posts: 2,027
broknlgs24 is on a distinguished road
everything was connected as per IFlyX5's
instructions. i just checked again. i also,
unplugged all connections and hooked the
CD Changer back up as normal. the CD
Changer worked properly. although, i noticed
something strange. w/ the radio playing, when
i press MODE once, it goes to the changer. when
i press it a 2nd time, it goes to the Cassette Player.
a 3rd press, it remains on the Cassette Player. a
4th press and it returns to the radio.
__________________
Reply With Quote
  #6  
Old 01-14-2006, 06:46 PM
broknlgs24's Avatar
Premier Member
 
Join Date: Mar 2005
Location: Maryland
Posts: 2,027
broknlgs24 is on a distinguished road
i connected just the Changer and all was fine.
i disconnected the changer and connected just
Sirius. obviously, the Changer was no longer
available when i pressed MODE. still though,
i did not see SAT. when i pressed MODE, it
just switched from the radio to NO TAPE.
__________________
Reply With Quote
  #7  
Old 01-14-2006, 06:56 PM
broknlgs24's Avatar
Premier Member
 
Join Date: Mar 2005
Location: Maryland
Posts: 2,027
broknlgs24 is on a distinguished road
- more test results -

i just went out to check the extension cable
(84.11.0.141.977). what i did was, plus that
cable into the factory cd changer wires and then
plug the other end into the changer instead of the
sirius receiver. the changer again was recognized.

so, it's not that cable. in doing this though, w/ the
radio playing the MODE button began working as follows :

1st press - changer
2nd press - NO TAPE
3rd press - radio

if, after pressing it the 2nd time, i did not press it a 3rd time, the
CD Changer would be playing still.
__________________

Last edited by broknlgs24; 01-14-2006 at 07:01 PM.
Reply With Quote
  #8  
Old 01-14-2006, 07:28 PM
broknlgs24's Avatar
Premier Member
 
Join Date: Mar 2005
Location: Maryland
Posts: 2,027
broknlgs24 is on a distinguished road
how can i tell if the radio module is from an '04 or newer?
i'm also a little confused as to what the part # of my radio
module is. the Becker sticker has it as 65.12-6 964 398.
there's a generic BMW sticker that says 65.12-6 964 399.
__________________
Reply With Quote
  #9  
Old 01-14-2006, 07:51 PM
broknlgs24's Avatar
Premier Member
 
Join Date: Mar 2005
Location: Maryland
Posts: 2,027
broknlgs24 is on a distinguished road
- more info -

i went into the Service Menu to verify that the
receiver was in USA mode and it was. the software
version was 41-04 95. i'm at a complete loss here.
something is definitely being detected when i press MODE though.
instead of going from radio - changer - NO TAPE - radio; it goes
radio - changer - NO TAPE - NO TAPE - radio.
__________________
Reply With Quote
  #10  
Old 01-16-2006, 01:09 PM
broknlgs24's Avatar
Premier Member
 
Join Date: Mar 2005
Location: Maryland
Posts: 2,027
broknlgs24 is on a distinguished road
anyone have any suggestions?
__________________
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 03:46 AM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.