Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > Electronics > Navigation System
Fluid Motor Union
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read

Xoutpost server transfer and maintenance is occurring....
Xoutpost is currently undergoing a planned server migration.... stay tuned for new developments.... sincerely, the management


Reply
 
LinkBack Thread Tools Display Modes
  #481  
Old 07-22-2009, 11:08 AM
Member
 
Join Date: Dec 2006
Location: Switzerland
Posts: 2,575
KiwiJochen is on a distinguished road
Quote:
Originally Posted by TJJ View Post
Are you sure? When I first got the MK4-navigation unit, I seem to recall that it had just two languages, DE and FR. What happens if you put for example FF to the last language bits of the hex line that changes the languages? Crash and burn...?
It reverts to default. If you load 3 x FF FF FF, it loads DE FR EN, because default is DE FR EN

I think if you set a language that doesn't exist, ie: 1F, then it may default to 00 (German)

But try it and report back to me :-)
Reply With Quote

Sponsored Links

  #482  
Old 07-22-2009, 11:12 AM
ccfj1's Avatar
Member
 
Join Date: Sep 2006
Location: The UK.
Posts: 1,931
ccfj1 is on a distinguished road
Quote:
Originally Posted by KiwiJochen View Post
You must load 3 x DIFFERENT languages

The nav will not change languages properly if you set 2 or 3 languages the same

Try it and see what happens :-)
I did this with my mk4 and tried to load the UK Fem and the UK male and it did not like it at all..

Load Eng and ITA then any other, then blank it out using navtweak.

Quote:

The command is defined in the nav OS software somewhere, I don't know where.
You would have to decompile and reverse engineer the operating system to find where.
OS is a special version of OS9000
Jochen is right, good luck with that, I've been tiring to get a copy of normal OS9000 and it virtually impossible, never mind the decompile/recompile.
__________________
Sept 03, M3, Silver Grey. Retro-fits: Modded Mk4 DVD Drive, OEM Bluetooth, VR Control, Rainbow Speaker Upgrade, Sony SOT Amp, HK Sub, CCFL, Intravee II, NightMode.
Reply With Quote
  #483  
Old 07-22-2009, 11:24 AM
TJJ TJJ is offline
Member
 
Join Date: Sep 2005
Location: X5world
Posts: 50
TJJ is on a distinguished road
Quote:
Originally Posted by KiwiJochen View Post
You must load 3 x DIFFERENT languages

The nav will not change languages properly if you set 2 or 3 languages the same

Try it and see what happens :-)
I have already tried that... Did not work. So looks like it's not possible to have 3 different languages that all change car to EN? I now have GB and US but all others that have translatable text strings switch car to DE, FR, IT or ES. Or have I missed something?
Reply With Quote
  #484  
Old 07-23-2009, 11:51 AM
Member
 
Join Date: Dec 2006
Location: Switzerland
Posts: 2,575
KiwiJochen is on a distinguished road
Quote:
Originally Posted by TJJ View Post
I have already tried that... Did not work. So looks like it's not possible to have 3 different languages that all change car to EN? I now have GB and US but all others that have translatable text strings switch car to DE, FR, IT or ES. Or have I missed something?
You are right

Remember: the language is defined by the language number
00=German
01=English
02=US English etc
(not sure if 01 and 02 are correct, but you understand what I mean)

The car is not designed to have 2 x the same languages in the nav.
Reply With Quote
  #485  
Old 07-31-2009, 06:04 AM
PSQ PSQ is offline
Member
 
Join Date: Jul 2009
Location: Poland
Posts: 1
PSQ is on a distinguished road
Hi,
I have a problem with NavTweak and a modules file from Carminat 8000 software. All files are read by NavTweak except file where are language modules (program is hanging).
What I have to do, to edit this file?
Thanks for your answers.
Reply With Quote
  #486  
Old 08-21-2009, 12:33 PM
Member
 
Join Date: Mar 2009
Location: Cincinnati OH
Posts: 18
Hdhntr23 is on a distinguished road
Can you guys help me with creating a new disc?

Here is what I have done so far and I seemed to have gotten lost somewhere.

I have copied the files from a known working disc for update v31 with night vision over to its own directory on my hdd.

I can open NavTweak up, Ive drilled to the navboot file. I can edit the changes I want etc etc.

I just cant for the life of me figure out what to do next.

Do I save that edited navboot file back into the directory it came out of? Do I name it as navboot?

Do I then copy all those files in that directory I created on my HDD over to a disc and burn it as an ISO?

Ive read the thread and I see instructions for burning but I cant seem to get my edited files back to an iso thats where Im getting lost.

Do I copy all of the files to a new CD or, is there a certain file that I burn? Reason I ask is because everytime I try to burn just the navboot file it says unexpected file format cannot proceed. Or something of the like.

Any help in laymens terms would really help.

Thanks!
Reply With Quote
  #487  
Old 08-23-2009, 07:19 AM
ccfj1's Avatar
Member
 
Join Date: Sep 2006
Location: The UK.
Posts: 1,931
ccfj1 is on a distinguished road
Don't do it this way unless you have a mk3.

if you have a mk4, then open the image of the v31/v32 (using ultraiso or magiciso etc) and then drag and drop the navboot to the same dir that you have navtweak, then do the edits and save (as navboot), then drag and drop the new navboot back into the open v32 image (using ultraiso or magiciso etc) and then save as a new image (eg v31_mine.iso), the use imgburn to burn the new image to disc, remember to use the slowest rated speed of the disc or x1 speed.
__________________
Sept 03, M3, Silver Grey. Retro-fits: Modded Mk4 DVD Drive, OEM Bluetooth, VR Control, Rainbow Speaker Upgrade, Sony SOT Amp, HK Sub, CCFL, Intravee II, NightMode.
Reply With Quote
  #488  
Old 09-20-2009, 11:04 AM
Member
 
Join Date: May 2008
Location: sc
Posts: 117
corima is on a distinguished road
Well, I must be the biggest Noob around. Downloaded all components( I think) of navspeak and navtweak. Still cant get it to run on my laptop. Its a 64bit, does that make any difference? Thanks
Reply With Quote
  #489  
Old 09-21-2009, 01:20 AM
Scuba's Avatar
Member
 
Join Date: Mar 2008
Location: n/a
Posts: 257
Scuba is on a distinguished road
Did you install GTK libraries?
Reply With Quote
  #490  
Old 09-21-2009, 12:06 PM
Member
 
Join Date: May 2008
Location: sc
Posts: 117
corima is on a distinguished road
do I need to load all 4 of the gtk files, and the 2 glade files?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -4. The time now is 01:18 AM.
vBulletin, Copyright 2019, Jelsoft Enterprises Ltd. SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.