Xoutpost.com

Xoutpost.com (https://xoutpost.com/forums.php)
-   X5 (E53) Forum (https://xoutpost.com/bmw-sav-forums/x5-e53-forum/)
-   -   What did you do to / for your E53 today?? (https://xoutpost.com/bmw-sav-forums/x5-e53-forum/78921-what-did-you-do-your-e53-today.html)

snik 12-08-2018 07:13 PM

Quote:

Originally Posted by bcredliner (Post 1148547)
Another option- drill a hole in the truck and run the wire directly to the backup camera. Secure using the existing slot in the trailer hitch cover so it is centered between the parking distance sensors.



What is that in the 2nd pic?


Sent from my iPhone using Tapatalk

mr_robot 12-08-2018 07:20 PM

What did you do to / for your E53 today??
 
Water/meth injection.

Are you boosted BC?


Sent from my iPhone using Tapatalk Pro

SlickGT1 12-08-2018 07:58 PM

Quote:

Originally Posted by mr_robot (Post 1148551)
Water/meth injection.

Are you boosted BC?


Sent from my iPhone using Tapatalk Pro

Pretty sure he has a supercharger and NOS, the big bottle.

Ryoken 12-09-2018 08:17 AM

dropped oil , refilled with new shell helix ultra , lets see if this works :)
oh and I cleaned the inside of the windscreen as it was filthy

sidneyj 12-09-2018 11:18 AM

Quote:

Originally Posted by Overboost (Post 1148544)
I'm pretty happy with the camera. 120 degree FOV and clear for standard definition. It looks crappy from my phone picture through a cheap stand alone monitor but it looks great on the monitor itself. At least I know the routing and wiring was a success and the mirror reverse image is correct! I cut the wire for the parking lines and plan to have the option to turn them on or off in the app. :thumbup:

Nice! I want that. Is there an install write up somewhere and a link to that camera? What head unit you have now? Would this camera work on the factory head unit?

Overboost 12-09-2018 11:34 AM

Quote:

Originally Posted by sidneyj (Post 1148594)
Nice! I want that. Is there an install write up somewhere and a link to that camera? What head unit you have now? Would this camera work on the factory head unit?

All the credit on this one goes to one our our members Crowz. He did this a year ago and documented the install along with a link to the camera on Amazon. I spent $20 delivered for this one.

Backup-Reverse Camera | Crowz Nest

I'm sure this would work with the factory head unit but I think you need the factory TV module along with the factory navigation. I have not personally done this install for the factory navigation systems but there are a few of our members that have.

https://xoutpost.com/bmw-sav-forums/...avigation.html

My am converting my X5 over to the android system and putting the camera in ahead of time was just to get it out of the way. It does take a few hours to do it right.

bcredliner 12-09-2018 03:20 PM

Quote:

Originally Posted by snik (Post 1148550)
What is that in the 2nd pic?


Sent from my iPhone using Tapatalk

That's the meth injection pump. Running Snow meth injection with controller and 150 shot of nitrous. Meth is to prevent spark knock by increasing effective octane.

sandbagger 12-09-2018 04:09 PM

Nokian hakkapeliitta r3 are all set to go but still sitting in the garage, waiting till the snow is about to fly before bolting them up

should be interesting to see how these stand up to the Pirelli Scorpion Ice and Snows I had on it prior. The Nokians were only about $8each more expensive so I decided to go with the Gold Standard :)

Fifty150hs 12-09-2018 08:21 PM

Put my rebuilt calipers on and new Zimmerman rotors and Akebono pads. Bled the system three times and brakes are kind of mushy. Going to have to get more brake fluid and do an ABS and precharge pump bleed with my Schwaben tool. Strange. Followed the Bentley instructions when changing the calipers and got virtually no brake fluid leaking from the lines. Bled with a power bleeder. I dunno.

crystalworks 12-10-2018 01:44 AM

This weekend saw some work on big red.

Replaced the 5 bulbs behind the instrument cluster with new. One of mine had blown out and so replaced all of them.

Also got all of this ready to go to the body shop. Removed most of the double sided tape/reside and degreased/washed most of the parts so the painter wouldn't have to waste too much time. Painter picked everything up Friday evening. Supposed to be ready tomorrow, but if it's not ready until the end of the week that's fine. I'd rather it be done right than fast.

https://i.postimg.cc/WpF7kcHD/20181207-174122.jpg

Also got under the truck to assess the condition of the seals. Last oil change I had done was at the dealer (was really pressed for time) and they used the OE fluids... so of course it found every failing seal possible. Started degreasing it and will clean it all up. Going to drop the oil that's in it and refill with the not-so-secret sauce. Hadn't had a problem with these type of leaks in the past so hoping this will buy me a few months to complete a few other obligations before tackling a huge engine maintenance list.

https://i.postimg.cc/4yQvxsWn/20181208-121933.jpg

https://i.postimg.cc/J7N5q5Rm/20181208-121942.jpg

While down there I checked all the torque values on the front suspension rebuild I had done because I had a clunk from the front end when changing directions (FWD to REV, and vice versa). All of the fasteners were good save the front tension arms connection at the bushing to the subframe. Those were considerably loose. Not loose, but not torqued either, got another half turn or so... torqued them down to 122ftlbs and we'll see if that helps the noise after she's back together.


All times are GMT -4. The time now is 03:29 AM.

vBulletin, Copyright 2022, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
2017 Xoutpost.com. All rights reserved.